2

I have just upgraded my dual-boot desktop from Kubuntu 16.04 to 18.04 using the link which popped up. Obviously the internet was connected for the upgrade, but although the dialog box on the panel says I have a wired 802.3 connection as hitherto, Firefox can't access the internet.

I have tried Question 453401, now 4 years old, but can't get beyond the first stage - so I changed the Network managed back to false and hope for a reply. At the top left of the network panel dialog box, there are blank square and a red plane icons. I have experimented changing the square to blue and the plane to white, but no joy. Please help.

Thanks for help valiano and guiverc. The pings didn't work, but the hardware list was as follows:

WGCman@WGCman-Z97P-D3:~$ sudo lshw -C network 
[sudo] password for WGCman:  
 *-network                  
      description: Ethernet interface 
      product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
      vendor: Realtek Semiconductor Co., Ltd. 
      physical id: 0 
      bus info: pci@0000:03:00.0 
      logical name: eth0 
      version: 06 
      serial: fc:aa:14:06:42:8d 
      size: 100Mbit/s 
      capacity: 1Gbit/s 
      width: 64 bits 
      clock: 33MHz 
      capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 10
0bt-fd 1000bt 1000bt-fd autonegotiation 
      configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=
rtl8168e-3_0.0.4 03/27/12 ip=192.168.1.10 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s 
      resources: irq:18 ioport:d000(size=256) memory:f7900000-f7900fff memory:f2100000-f2103fff 

WGCman@WGCman-Z97P-D3:~$ ip addr 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 
   link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 
   inet 127.0.0.1/8 scope host lo 
      valid_lft forever preferred_lft forever 
   inet6 ::1/128 scope host  
      valid_lft forever preferred_lft forever 
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000 
   link/ether fc:aa:14:06:42:8d brd ff:ff:ff:ff:ff:ff 
   inet 192.168.1.10/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0 
      valid_lft 85494sec preferred_lft 85494sec 
   inet6 fe80::7f22:4323:b7c0:9131/64 scope link noprefixroute  
      valid_lft forever preferred_lft forever 

WGCman@WGCman-Z97P-D3:~$ ping 192.168.1.1 
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data. 
From 192.168.1.10 icmp_seq=1 Destination Host Unreachable 
From 192.168.1.10 icmp_seq=2 Destination Host Unreachable

WGCman@WGCman-Z97P-D3:~$ ping 8.8.8.8 
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 
64 bytes from 8.8.8.8: icmp_seq=1 ttl=121 time=19.7 ms 
64 bytes from 8.8.8.8: icmp_seq=2 ttl=121 time=15.0 ms

WGCman@WGCman-Z97P-D3:~$ ping google.com 
ping: google.com: Temporary failure in name resolution 
WGCman@WGCman-Z97P-D3:~$

Thanks, David, The Script returns: --2018-09-13 20:43:08--  https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info Resolving github.com (github.com)... failed: Temporary failure in name resolution. wget: unable to resolve host address ‘github.com’ This looks unhelpful and is probably because my computer cannot access the internet either wirelessly or via ethernet (Powerline Plug) with Kubuntu 18.04, though it could with 16.04 and still can with Windows 10. After a recent W10 upgrade I had to resubmit the wireless key for the dongle to work, but the Kubuntu upgrade has not asked for any passwords. I note the instructions in your link to send files across to a device with internet access - with my dual boot machine this should be easy! - but it doesn't say which files.

2
  • sudo lshw -C network will list.hardware network class of devices only, and add it to your question please. I'd also type ip addr to see if device is there, and if it has an ip address, eg. my workstation shows device enp0s25 with ip address 192.168.1.19/24. I would ip route to see if anything is there, it shows my gateway is 192.168.1.1 so I can ping 192.168.1.1 and see if i get a response. Next I ping google [dns] using ping 8.8.8.8 and see if i get a response. Next I use a human name for google, ie. ping google.com - do any work for you?? Each test a little further. – guiverc Sep 9 '18 at 8:19
  • Welcome to Ask Ubuntu! Could you please run the network diagnostics and edit your question to include a link to the result? I know it may seem a bit overwhelming for a novice but your info so far is a bit vague and the diagnostics will likely cover all options that may cause your issue. Thanks. – David Foerster Sep 12 '18 at 10:09
1
  • Find the file /etc/NetworkManager/NetworkManager.conf.
  • Edit and change managed=false to managed=true.
  • From the top-right corner select Edit Connections, and add a new connection. Specify your ip address, netmask, gateway, and the DNS server being 8.8.8.8.
  • Then run: sudo service network-manager restart.
  • Also run sudo service network-interface restart INTERFACE=eth0
3
  • Thanks. How do I find ip address etc, this info is no longer availabke? – WGCman Sep 19 '18 at 11:10
  • Got Ip Addr etc from Windows. But I couldn't close the dialog with 8.8.8.8., so had to use 192.168.1.254 (default) instead. Still no Internet with Kubuntu. Many thanks for trying. Slower graphics also: 18.04 unfit for purpose. Back to M$, I'm afraid. – WGCman Sep 20 '18 at 17:03
  • I had a similar problem in an dist-upgrade from 16.04 LTS to 18.04 LTS. Static address with known connection parameters (included dedicated DNS server). The point was to change the managed=false in managed=true in the NetworkManager.conf file and simply restart the service sudo service network-manager restart. It worked. – Hastur Sep 4 '19 at 16:05
0

I had the same problem after upgrading from Kubuntu 16.04 to 18.04 (my WiFi was working but the ethernet port was disabled). The answer above worked except I didn't need to run:

$sudo service network-interface restart INTERFACE=eth0

BTW, the INTERFACE here is the logical interface (not eth0) that you should get with:

$sudo lshw -C network

My point about posting this. I tried multiple other answers none of which worked for me. These were: USB Ethernet interface in virtual Ubuntu 18.04 disabled after every reboot

https://ubuntuforums.org/showthread.php?t=2390635

and https://ubuntuforums.org/showthread.php?t=2398603

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.