4

Since I had driver problems with nouveau on my Thinkpad (flickering external monitor on docking station) I switched to nvidia-390 and also to nvidia-396 both without success (didn't even recognize the external screen on docking station).

Now I want to switch back to nouveau since then at least the external monitor worked if I connect it via mini-dp.

However I cannot switch back anymore. I did the following steps:

  • sudo apt-get purge '*-nvidia-*'
  • removed /etc/modprobe.d/blacklist-nouveau.conf (which I created when installing nvidia)
  • sudo update-initramfs -u
  • sudo reinstall xserver-xorg-core libgl1-mesa-glx xserver-xorg-video-nouveau
  • There was no /etc/X11/xorg.conf to remove or to modify
  • reboot

However then lspci -nnk | grep -iA2 vga returns that

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
    Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f5]
    Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K2000M] [10de:0ffb] (rev a1)
    Subsystem: Lenovo GK107GLM [Quadro K2000M] [17aa:21f5]
    Kernel modules: nvidiafb, nouveau

I.e. additionally to nouveau there seems to be nvidiafb active. Then I tried to blacklist nvidiafb without success.

I also tried to disable framebuffer as described in the arch wiki also without success.

The problem is that this configuration doesn't recognize any external monitor even on mini-dp. I just realized that even VGA doesn't work.

Any idea of how I can make it work?

Are there any settings or files I should check to diagnose the cause of the problem?

  • Looks like you did successfully revert to nouveau, not sure why the title says "can't revert...". The question makes no sense as is. – mikewhatever Sep 9 '18 at 9:12
  • @mikewhatever I thought that lspci -nnk | grep -iA2 vga should outpout only nouveau in the last line and not nvidiafb. Or is nvidiafb correct in this case? – student Sep 9 '18 at 10:17
  • The point is that before I tested nvidia the external screen worked via mini-dp and nouveau driver. After my attempt to revert to nouveau this doesn't work anymore. So the reversion doesn't work as expected. – student Sep 9 '18 at 10:19
1

Try sudo apt-get purge nvidia* to -clears all nvidia items

Type sudo apt-get install xserver-xorg-video-nouveau

Then reboot your system.

If this don't work try sudo dpkg-reconfigure xserver-xorg

If this also doesn't work try to add this ppa sudo add-apt-repository ppa:graphics-drivers and run sudo apt-get update

Install (and activate) the latest Nvidia graphics drivers.Enter the following command to install the version of Nvidia graphics supported by your graphics card

sudo apt-get install nvidia-370

Reboot your computer for the new driver to kick-in. You can check your installation status with the following command

lsmod | grep nvidia

If there is no output, then your installation has probably failed. It is also possible that the driver is not available in your system's driver database. You can run the following command to check if your system is running on the open source driver nouveau. If the output is negative for nouveau, then all is well with your installation.

lsmod | grep nouveau

Prevent automatic updates that might break the drivers. You can do this in 2 ways

  1. By removing the graphics-drivers PPA from your software sourcesThis will depend on your distro. On Ubuntu, go to your software sources, and then other sources and remove all instances of the graphics-driver PPAs.
  2. List item Or by blocking minor version updates. Enter the following command

    sudo apt-mark hold nvidia-370

  • 1
    I tried all of your suggestions but nothing worked. – student Sep 18 '18 at 12:34
0

You should uninstall completely the nvidia driver.

sudo apt autoremove *nvidia-*

Be careful what dependencies are removed before validating the uninstall !!

  • I already did sudo apt-get purge '*-nvidia-*'. I also tried your command but it didn't remove anymore packages. By the way I think you need to use quotes, i.e. 'nvidia-'` to make expansion work. At least for my system this is the case. – student Sep 9 '18 at 7:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.