10

This bug poisons my ubuntu experience. When the pc resumes (re-open the lid) the windows are re-sized. See example below (screenshot) for FF:

enter image description here

Is there anything I can switch off to fix this?

  • 1
    I also have this issue. – vanadium Sep 9 '18 at 11:18
9

I had exactly the same problem and I had real trouble finding a solution. Eventually, I solved it by turning off Gnome's automatic window scaling. You can check your current setting with the following:

gsettings get org.gnome.desktop.interface scaling-factor

If this returns a value of uint32 0, then it means you have automatic scaling turned on. I found that setting this to a specific value (in my case 1) fixed the issue, which you can do using the following:

gsettings set org.gnome.desktop.interface scaling-factor 1

I discovered this by following this answer about scaling gnome's login screen. The problem seems to be caused by a mismatch between the login screen and desktop scaling factors.

| improve this answer | |
  • 1
    My issue wasn't solved when I set scaling-factor to 2; I'm running Bionic on a desktop with a 4K display on 200% scaling, and widows are resized after I lock the screen and then resume. – Jonathan Y. Feb 27 '19 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.