1

so i would like to use my external Sound card i have, Behringer U-Control UCA200, to record my Guitar because my Laptop doesn't have a Line in port This is a USB sound card.

I have connected the Guitar in the input port and the output of the Sound card to the speakers. The Card itself is connected to one USB port of the laptop.

I was hoping this would be Plug n Play, means that i will play the guitar and listen to some sound but obviously i need to make Linux understand that there is a Sound Card connect to the USb port.

Any help very welcome

I attach the connection and the sound card

Sound Card and Cables

$ lsusb |grep -i audio'
Bus 001 Device 003: ID 08bb:2902 Texas Instruments PCM2902 Audio Codec

and

$ sudo lshw -class sound

  *-usb:1    

   description: Audio device
   product: USB Audio CODEC
   vendor: Burr-Brown from TI
   physical id: 2
   bus info: usb@1:2
   version: 1.00
   capabilities: usb-1.10 audio-control
   configuration: driver=usbhid maxpower=100mA speed=12Mbit/s

 *-multimedia
   description: Audio device
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 1f.3
   bus info: pci@0000:00:1f.3
   version: 21
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list
   configuration: driver=snd_hda_intel latency=64
   resources: irq:131 memory:e1244000-e1247fff memory:e1230000-e123ffff

i also attach my Sound Settings Input: Audio Input and my Alsamixer screen Alsamixer Even though my Alsamixer is showing the USB Sound Card the Sound Settings says Analog Input.

This setting enables Audacity to hear your guitar while recording Audacity Settings

  • have you looked in settings->sound and selected your USB device as default input/output? also, can you post the output "lsusb |grep -i audio" and "sudo lshw -class sound" " – Joshua Besneatte Sep 8 '18 at 14:40
  • the Device is not visible in the Sound Settings – xbass540 Sep 8 '18 at 15:05
  • 1
    yup just edited the whole thing, thanks! Looking forward to make this work :) – xbass540 Sep 8 '18 at 15:10
  • "I need at least 10 reputation to post images" lol thanks though! – xbass540 Sep 8 '18 at 15:14
  • can you post a screenshot of your sound settings? also, what version of ubuntu are you using? – Joshua Besneatte Sep 8 '18 at 15:24
0

We can see that your system is recognizing the sound hardware. First thing to try is to go into Settings -> Sound and under the Output and Input tabs, make sure your usb device is selected. It might be called something different like "Analog Input/Output" you might need to use some trial and error.

Once the input device is selected, you should see the input level meter reacting to your guitar.

Once the output device is selected, you should be able to play sound through the card.

If you don't see this card in your setting for some reason, see if alsamixer recognizes it.

alsamixer

and press f6 to get a list of audio devices. Does it show there? If so make sure to show all the channels and ensure none of them are muted.

You should then be able to use Audacity to record:

sudo apt install audacity

Run Audacity and test your recording/playback. If your device supports duplex, you can go to Edit->Preferences->Recording and select both boxes in "playthrough" so you can listen while you play.

If you want to really be able to tweak your sound system, or if you are doing serious recording you will want to use the Jack Audio Connection Kit.

sudo apt install jack

If you want to get the most out of Linux audio production, I recommend having a look at this guide:

Ubuntu Studio Audio Handbook

|improve this answer|||||
  • So i managed to record my guitar into Audacity but i cant hear any sound while playing. Is this normal?I need this because i want to play the guitar on top of some rhythm. – xbass540 Sep 8 '18 at 15:38
  • added some more info to answer... you might need to tweak audacity settings. if this answer worked for you be sure to accept it by clicking the checkmark under the voting arrows on the left of the question. thanks! – Joshua Besneatte Sep 8 '18 at 15:51
  • 1
    ok i think we solved it: I now am able to record some guitar parts on one channel and then while playing the 1st channel i can play along with my guitar and record on the second channel, one last question please: why i can hear the guitar only when i press record? I would expect it to sound even when i am outside Audacity, right? – xbass540 Sep 8 '18 at 15:52
  • actually no... the guitar will only loop to the output if told to do so... imagine if a microphone always played through the speakers... super feedback time! if you want to use your computer as an amp for your guitar you will need to play with jack – Joshua Besneatte Sep 8 '18 at 15:54
  • ok sounds reasonable, so like said i can do staff now, thanks grand!!! I click the checkmark now – xbass540 Sep 8 '18 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.