2

After I initiate power off/restart, system usually lead to a black screen as shown below or the basic Ubuntu logo screen

black screen

Then it freezes right on that screen or the display turns off yet the system keeps running. The hard drive and mother board active notification light remains on and within a few second of being frozen the CPU cooling fan speeds up.

I have to press the power button for 10 sec to shut it down. I have been facing this problem since I have installed Ubuntu 18.04.

I have tried couple of provided solution given in askubuntu but nothing worked(although didn't tried all due my limited knowledge)

I have tried grub edit method and I have tried sudo shutdown -h nowand similar commands like it, nothing worked you will see in the image I provided, there is something like "firmware update deamon[started]" so, I looked into the log for some bug related to firmware and found couple of them but to newbie to do something about them.

Also the OS freezes sometimes during regular task like Web browsing.

system info:

  • processor-Intel® Pentium(R) CPU N3520 @ 2.16GHz × 4
  • memory-2 GB
  • graphics-Intel® Bay Trail
  • OS type-64-bit
  • gnome-3.28.2

Laptops details- - Acer Aspire E-1 series Model-Z5WE3

Existing hardware problem-

  • Battery is out of work
  • Inbuilt keyboard have button pressed issue( currently floated with xinput(I don't think this is the cause because I had this problem even before I floated the buit-in keyboard)

I think the freeze of OS during casual work and freeze during shut down are caused by same bug. Although OS freeze during casual work is rare.

Please help I am too Newbie to solve this problem by myself. I reinstalled Ubuntu but the problem is still here.

P.S- I installed Ubuntu 18.04 with a USB drive not by CD/DVD rom

2 Answers 2

1

I found the issue, it is caused by Intel bay trail cores. Now I have the solution too which isn't the best yet it is decent for now.

Solution:

  • Onpen terminal
  • sudo gedit /etc/default/grub
  • EditGRUB_CMDLINE_LINUX_DEFAULT="quite splash"into GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1"
  • Save and close it
  • sudo update-grub
  • Turn your computer off forcefully for one last time

I had this problem since I have installed Ubuntu 18.04 and I was kind of motivated to erase it but I am a newbie and it is serious bug. The solution isn't the best but good for now at least.

0

In my case, I use driver nouveau

Solution:

Open terminal

sudo gedit /etc/default/grub

Add the lines in:::

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_rev_override=1 nouveau.modeset=0"

Save it

sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.