1

My old laptop (Samsung np300v3a, running fresh Ubuntu 18.04) has a broken left trackpad button, that is always pressed. I have been trying to disable the physical keys, but keep the tap to click in order to retain this use of the trackpad.

I've tried modifying xinput button-map, set-props, and some synclient options. I can disable the left click with xinput, but this also disables the tap to click function.

Threads I've read:
Disabling One-Finger Tap-to-Click But Keep Two-Finger tap Ubuntu 12.04
How to disable physical mouse buttons below touchpad

0

If you upgrade to at least Ubuntu 18.10 or 19.04, there is a simple way :

create the file (and the directory) :

/etc/libinput/local-overrides.quirks

put in it this :

[disable physical button of touchpad]
MatchUdevType=touchpad
MatchBus=ps2
AttrEventCodeDisable=BTN_LEFT

It work fine on my sony vaio pro 13. You may have to tweak the Match* lines, have a look at : https://wayland.freedesktop.org/libinput/doc/1.13.0/device-configuration-via-udev.html

good luck

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.