1

It's a Server (Dell PowerEdge R730xd)

The CPU is Intel Xeon E5 2630 v4 2.2GHz

The OS and kernel is Ubuntu 16.04 and 4.15.0-33-generic

The current settings are as follows:

  1. intel_pstate is disabled

Add "intel_pstate=disable" to /etc/default/grub

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver will show acpi-cpufreq

  1. Use userspace governor

sudo cpupower frequency-set -g userspace

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor will show userspace

  1. Set a target frequency

sudo cpupower frequency-set -f 2.2G

cat /sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq will show 2200000

However, by using watch -n 1 "cat /proc/cpuinfo | grep MHz" to monitor the current CPU frequency, I find that the frequency is always changing. (Using i7z is the same)

Only when the load becomes higher (e.g., use stress -c 40) the CPU frequency will remaine stable in 2.2GHz.

The current BIOS power management settings are as follows:

  • CPU Power Management -> OS DBPM (i.e., OS Control)
  • Memory Frequency -> Maximum Performance
  • Turbo Boost -> Disabled
  • C1E -> Disabled (When set to Enabled, the processor is allowed to switch to minimum performance state when idle)
  • C States -> Disabled (C States allow the processor to enter lower power states when idle)
  • Collaborative CPU Performace Control -> Enabled
  • Uncore Frequency -> Maximum
  • Energy Efficient Policy -> Performance (And there are other options, e.g., Balanced Performance / Balanced Energy / Energy Efficient
  • Monitor/Mwait -> Enabled

So, how can I lock my CPU frequency?! Many thanks!

  • 1
    The problem has been solved. By adding "idle = poll" to grub to disable C state. – ppang Sep 12 '18 at 3:33

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.