7

My machine has Ubuntu 18.04 installed.

I use Google Chrome and I often work with Jupyter Notebooks.

When I launch the browser everything seems to work fine. After some time (~ 1-2 hours) the address bar and the tabs part turn black as shown below.

enter image description here

Not happy.


Graphics Card: NVIDIA Quadro M4000

The problem persists both when I use the NVIDIA proprietary driver and when I use the open source X.Org X server driver.

  • Check if disabling chrome "hardware acceleration" in settings changes this behavior. – Michal Przybylowicz Sep 7 '18 at 15:56
  • What would be the side effects? – Sandu Ursu Sep 28 '18 at 11:17
  • 1
    @SanduUrsu It uses more CPU power. – Chai T. Rex Oct 2 '18 at 21:50
5

I have exactly the same issue with Chromium and Quadro M4000M (ThinkPad P70) on Arch Linux (xmonad, nouveau). So my conclusion is, that there is a bug in chromium that was introduced in the last year. Probably Quadro / M4000 related. It worked before with Nouveau and Nvidia driver.

I am not aware of any solution to fix it, but there are some workarounds:

  • You can drag and drop the tabs to another browser window and recover them manually.

  • You can use a browser plugin like OneTab to save and close all affected tabs. Then open a new window and restore all saved tabs (use mouse hover to find the OneTab button).

  • Disabling hardware acceleration in chrome settings could work, but you will lose some rendering performance.

Check results of chrome://gpu - It reports some issues for my system, not sure if it is related.

Could be related to GL ERROR :GL_OUT_OF_MEMORY : GLES2DecoderImpl::DoBindTexImage2DCHROMIUM: <- error from previous GL command

Update 1: I have created a bug report here: Issue 893117

2

It appears that there's an issue with the default display drivers on Ubuntu 18.04. I ran into the same issue ever since I installed (and reinstalled) Chrome and a possible work around is to use an alternative display driver.

I followed instructions from this page: https://www.linuxbabe.com/ubuntu/install-nvidia-driver-ubuntu-18-04

To summarize:

  • Search for Software & Updates:

Software & Updates

  • Navigate to Additional Drivers (it might take a few seconds to load):

Drivers

  • Select something other than the default X.Org.X server. This might require a reboot but since making the change I haven't had the Chrome issue happen again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.