0

Git worked without any problems in my ubuntu 16.04 VirtualBox VM hosted in Windows 7. But since I've upgraded the VM to 18.04 today all the commands git clone, git pull, git push fail without error. I've tried reinstalling git and rebooting but to no avail. git status and git commit, etc still work fine. It only seems to be the commands that involve connecting to a remote origin that fail. Unfortunately there's no error message, even when I use a --verbose flag on the commands.

I am behind a proxy and usually clone repos using https and a personal access token from GitHub. I think the first time I tried git push after upgrading to 18.04 there was a crash report but I must have asked not to be told again because I haven't seen them since. Now I can't track down any related bug report for this...

2
  • A workaround I've found is to git clone a repo using the git: URL rather than the https: URL for the repo - i.e., use ssh rather than https to authenticate. This works from the commandline but unfortunately other tools like PyCharm for example don't like the ssh approach (Git push/pull fails without error). Which means I'm forced to use the commandline for cloning, pushing, pulling until a proper solution is found. – snark Sep 10 '18 at 10:03
  • Ok - I can make PyCharm work with ssh if I configure it to use the native ssh executable rather than the built-in one (Settings > Version Control > Git > SSH Executable = Native) – snark Sep 10 '18 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.