2

I have MS Office 2007 in wine 3.6 on Kubuntu 18.04. If I launch several Word documents, sometimes the mouse scroll stops working when switching to another document. Sometimes this issue can be solved by pressing Alt twice or by minimizing and maximizing the window, but it works until the next window switch. I've noticed that sometimes the mouse scroll affects the background window, as if Ctrl has been pressed, i.e. changes the font size. Is there a way to solve this problem?

It doesn't work at other my machine as well, so I think there is something with wine or Plasma rather than system configuration.

  • If you install inxi and post the output of inxi -Fxxxz here by editing your post, people will get a better idea of your system. – DK Bose Sep 7 '18 at 9:37
  • It is known issue. For me it exists on all GPUs - integrated Intel, AMD APU, proprietary Nvidia. I did not find any solution. – N0rbert Sep 7 '18 at 9:48
  • @N0rbert Do you have any links with discussion on this problem, I didn't find any? – Michael O. Sep 7 '18 at 10:06
  • @MichaelO I mean for me it is known. I have not searched for it yet. – N0rbert Sep 7 '18 at 10:08
  • @N0rbert try my solution – Michael O. Sep 7 '18 at 11:17
1

OK, so I found a working solution when stumbled upon this post. First you have to do what has been said there:

Disabling desktop effects did not help. Unchecking "Allow windows manager to control the windows" had side effects (window always on foreground). What works for me with Word, Excel and Powerpoint is:

Start System Settings

Select Window Behaviour

Select Window Rules

Click "New..." to create a new Window Rules

Enter the description

Window Class: Regular Expression. I use .*\b(winword.exe|excel.exe|powerpnt.exe)\b.*

Check "Match whole window class"

Check on tab "Size & Position"

Check "Full screen": value Forced, No

Check "Ignore Requested Geometry": value Forced, Yes

This will allow you to resize MS apps. Then go to the tab "Appearance and workaround" and do the following:

"Prevent focus stealing" -> check -> Forced -> High priority

"Focus protection" -> check -> Forced -> High priority

(don't know how exactly it is in English, my system is in another language).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.