1

I have run into a weird problem on ubuntu 18.04 on kernel 4.15 (generic).

Today, I rebooted my perfectly working system and found that all the text had been replaced by these tiny placeholder rectangles everywhere!

how my desktop looks right now

I can't even fiddle with settings because I can't see them. The weird part is that all text in chrome works normally.

I have searched a bit and apparently this bug existed for 16.04 and was due to a kernel problem. The solution was to upgrade to a new kernel. I am on the latest ubuntu kernel so I don't really know what to do.

Could somebody here help?

Update

I solved the problem by referring to this link somewhere else on this site.

This can be the result of some invalid permissions settings on Font files. You need to set correct permissions for fonts.

To fix the permissions of all fonts ending with .ttf or .otf extension use these two commands.

find /usr/share/fonts -iname '*.ttf' -type f -exec sudo chmod -v 644 {} \;

find /usr/share/fonts -iname '*.otf' -type f -exec sudo chmod -v 644 {} \;

Then use this command to re-build font cache sudo fc-cache -r -v

This should fix the problem.

marked as duplicate by N0rbert, Eric Carvalho, Fabby, Thomas, pomsky Sep 8 '18 at 9:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I had an issue do this on 16.04 LTS; the cause was a change (tweak) I'd made in the prior session (the effect of loss of font wasn't noticed till next reboot). Thus I'd check your history (I use commands, and have my history log store date/times too), or your apt log (/var/log/apt/history.log etc), themes .. and see what you changed, undo it (or remove it, reboot) and you may find the problem solved. From memory the change (theme or whatever it was) I made was for a different version of gtk+/gnome to what ubuntu used. – guiverc Sep 7 '18 at 23:02