I'm trying to install docker-ce using this process.

When I run sudo apt-get install docker-ce I get

Setting up docker-ce (18.06.1~ce~3-0~ubuntu) ...
Job for docker.service failed because the control process exited with error code. See "systemctl status docker.service" and "journalctl -xe" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Thu 2018-09-06 16:19:50 BST; 3ms ago
     Docs: https://docs.docker.com
  Process: 20289 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILURE)
 Main PID: 20289 (code=exited, status=1/FAILURE)

Sep 06 16:19:50 henry-DT2216 systemd[1]: Failed to start Docker Application Container Engine.
Sep 06 16:19:50 henry-DT2216 systemd[1]: docker.service: Unit entered failed state.
Sep 06 16:19:50 henry-DT2216 systemd[1]: docker.service: Failed with result 'exit-code'.
dpkg: error processing package docker-ce (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anyone advise on the issue?


You must remove previous existing version of docker and docker engine before you install docker using docker installation guide.

sudo apt-get purge docker docker-engine

If you have already removed previous version of Docker and still have issue as mentioned,then you may have issue due networking ranges overlapping between your network or vpn and docker0 bridge interface.

Docker attempts to find if any of the standard private IP-ranges is available to use.

You can configure the default bridge network by providing the bip option different than your current network or vpn ip ranges along with the desired subnet in the daemon.json (default location at /etc/docker/daemon.json on Linux) file as shown in below example:

  "bip": ""

Restart the docker daemon

sudo systemctl restart docker
  • The issue was I was running a VPN. I removed that and it worked perfectly - thanks – HenryM Sep 6 '18 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.