8

I like the look of the Unity desktop more than GNOME, but with Unity, I can't use tap-to-click on my mousepad, is there a way to fix this?

13

Well, I don't know if Unity has some option for it, hopefully someone will answer on that one. But you can enable it from command line:

  1. list devices with xinput list, and find the touchpad name in the output.
  2. use a xinput set-prop "SynPS/2 Synaptics TouchPad" "libinput Tapping Enabled" 1, where the text in first quotes SynPS/2 Synaptics TouchPad needs to be replaced with touchpad name you got in step 1.

This will only work till reboot, so you'll need to add the command from step 2 to autostart.

2
  • Perfect! This is what I was looking for :) – Sai Nikhil Dec 18 '18 at 21:17
  • 3
    I upvoted your post by tapping my touchpad, thanks. – Amir Fo Jun 16 '19 at 12:09
3

Late Answer for those who see themselfes stumbling in this wide narrow sea.

If you are using a Synaptics device best thing would be installing the Synaptics drivers - The options you need will be added to the general settings under "Mouse and Touchpad".

EDIT: Apparently xf86-input-synaptics is not a synaptics driver, but still did the job for others and my machine(xps15).

To do so, first update everything

sudo apt-get update

and install the driver with

sudo apt-get install xserver-xorg-input-synaptics

In case that doen't work because you are missing dependencies, go for the HWE version;

sudo apt install xserver-xorg-input-synaptics-hwe-18.04

finally, restart and you should find the extended standard options in the system settings.

3
-1

I wouldn't use Unity in 18.04 as it is discontinued and you can customize Gnome quite a bit to emulate most of the features anyway, but, to each his own.

In any case, did you uninstall the Gnome utilities while installing Unity? If not, and you are using Xorg, you should see the option for tap-to-click in the Mouse & Touchpad settings.

mouse & touchpad settings

2
  • Sure gnome 'CAN' be great, but thats not the point. For me it was unusable due to all the lags, slow transitions and even lags on scrolling - despite the use of my GPU. It's just very poorly optimized for performance on new machines. – nonNumericalFloat Nov 30 '19 at 12:01
  • This setting does not help in Unity. It only affects the GNOME desktop. – starbeamrainbowlabs Oct 23 '20 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.