4

Every time I turn on my laptop, I see this error message about Lighttpd appearing several times while booting process (also on systemctl --failed):

Failed to start Lighttpd Daemon.
See 'systemctl status lighttpd.service' for details.

After logging in, I typed systemctl status lighttpd.service and got this output:

● lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2018-09-06 20:54:16 +05; 22min ago
  Process: 1170 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (code=exited, status=127)

Sen 06 20:54:16 ibrokhim-i systemd[1]: lighttpd.service: Service hold-off time over, scheduling restart.
Sen 06 20:54:16 ibrokhim-i systemd[1]: lighttpd.service: Scheduled restart job, restart counter is at 5.
Sen 06 20:54:16 ibrokhim-i systemd[1]: Stopped Lighttpd Daemon.
Sen 06 20:54:16 ibrokhim-i systemd[1]: lighttpd.service: Start request repeated too quickly.
Sen 06 20:54:16 ibrokhim-i systemd[1]: lighttpd.service: Failed with result 'exit-code'.
Sen 06 20:54:16 ibrokhim-i systemd[1]: Failed to start Lighttpd Daemon.

Also, this is the output from cat /etc/lighttpd/lighttpd.conf:

server.modules = (
    "mod_access",
    "mod_alias",
    "mod_compress",
    "mod_redirect",
)

server.document-root        = "/var/www/html"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"
server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80


index-file.names            = ( "index.php", "index.html", "index.lighttpd.html" )
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
## Use ipv6 if available
#include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"

How can I fix this problem?

6
  • Edit your question and show me more /var/log/lighttpd/error.log. Report back to @heynnema. Do you use this webserver? Is apache2 installed also?
    – heynnema
    Sep 6, 2018 at 18:25
  • @heynnema I thought bionic used gdm3? Sep 6, 2018 at 18:35
  • @GeorgeUdosen bionic does use gdm3... or lightdm. This OP is asking about lighttpd, which is a web server.
    – heynnema
    Sep 6, 2018 at 19:24
  • What webserver is this @heynnema? Sep 6, 2018 at 19:53
  • @GeorgeUdosen look in Synaptic.
    – heynnema
    Sep 6, 2018 at 19:56

3 Answers 3

7

Turns out this is a bug that's been around for years, if this issue is anything to go by. Several users in the comments of that bug claim that installing the gamin package solves this issue.

I haven't done any extensive testing, but it seems to be a solution. Running sudo apt install --reinstall lighttpd normally shows that it fails to start lighttpd. However, after installing gamin, the output looks like it normally would for any successful package installation. systemctl status also shows lighttpd as active and running now.

Note that the package libfam0 gets removed when installing gamin. I don't know what it's for, or what packages may depend on it, so keep that in mind, unless someone else can comment as to its usefulness and necessity.

2
  • This worked for me. Thanks
    – ldias
    May 15, 2020 at 17:29
  • Worked on Lubuntu 20.04 (Fecal Fossa).
    – zrajm
    Sep 11, 2020 at 8:20
3

I solved with this:

chown -R www-data:www-data /var/log/lighttpd/
1
  • 1
    Worked for me. Might also be helpful to chmod 755 /var/log/lighttpd in conjunction with the above command
    – Tran Situ
    Nov 19, 2019 at 7:09
0

So I had to do a purge to rid the system of the extra files:

sudo apt-get purge lighttpd

Then reinstall the software

sudo apt-get install lighttpd

This reset all of the .conf files, and other files

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.