2

I just installed Ubuntu Bionic (18.04.1) (Unity desktop) on both Oracle VB VirtualBox (5.2.18) and VMware Player (v14). I have Guest Additions on both VMs.

On VB, all graphics interactions are super slow. Opening the Dash takes forever (~ 1min) and opening both LibreOffice Write and Calc take several minutes.

The problem seems to be gnome-shell. When I use nmon, I see 1 CPU at 100% system wait state. When I kill a gnome-shell, that goes away -- for a while. I know gnome-shell is very 3-D graphics intenstive; but VMware doesn't seem to have this problem. I'd rather use VB, but I can't under these circumstances.

I have 3D acceration enabled on both, and I've checked /usr/lib/nux/unity_support_test. I'm using 8Gb Ram on both. I assigned 4 "CPUs". My host is a Dell XPS i7.

Has anyone else been able to get Unity on VB to run 'acceptably' like it's a real machine? It feels like something with the graphics emulation, but I can't figure out what? (Xubuntnu runs acceptibly on VB, but not Unity.)

2
  • 1
    Welcome to AskUbuntu! Care to share a bit more info on your setup? Which kind of hardware has the host to the VMs? Is it the same hardware for both the VirtualBox and the VMVare versions? – Mr Shunz Sep 6 '18 at 15:57
  • Set your VB settings to 2 CPU's, 2048 RAM, and video display memory higher. Report back to @heynnema. – heynnema Sep 6 '18 at 17:08
0

I think I found my own answrer.

I was originally stuck because I thought Ubuntu was using Unity GUI still. Nope. Not sure exactly when, but Canonical changed Ubuntu Desktop to Gnome UI. Once I tracked the system wait states to gnome-shell I had new info.

There is a known issue with Oracle Virtualbox + 3D Acceleration + Gnome UI. This post seems very complete:

Ubuntu 18.04 Gnome hangs on VirtualBox with 3D acceleration enabled

The possible solutions are to change any one of the above factors: use VMWare, turn off 3D Acceration, or use a different UI like Xubuntu or Lubuntu.

I can accept those solutions. I’ve tested all 3, and they do indeed solve the problem I was seeing super-long “unworkable” UI delays.

0

For me, it was resolved by changing a few settings:

  1. Base Memory 4096 MB (default was 512)

  2. Video Memory 128 MB (default was 16)

  3. 3D Acceleration enabled (default was disabled)

You might not need to change all of these to get a boost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.