2

Yesterday i updated my HP Laptop from Ubuntu 17.10 to 18.04. SInce then the wifi signal is very weak. I have tried all the options with downloading new driver from git. And tried with both ant_sel=1 and ant_sel=2 but both gives weak signal. In 17.10 ant_sel=2 used to work.

Any idea on what would have went wrong during the update?

Output of iwconfig : enp2s0 no wireless extensions.

lo no wireless extensions.

wlo1 IEEE 802.11 ESSID:"Sniper"
Mode:Managed Frequency:2.437 GHz Access Point: 94:65:2D:02:E3:91
Bit Rate=72.2 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off Link Quality=34/70 Signal level=-76 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:159 Missed beacon:0

siddharth@siddharth-HP-Notebook:~$ iwlist scan | egrep -i 'ssid|quality' enp2s0 Interface doesn't support scanning.

lo Interface doesn't support scanning.

                Quality=32/70  Signal level=-78 dBm  
                ESSID:"Sniper"

This is when i sit next to the modem.

I have done the below steps : 1) Cloned latest rtlwifi_new from git 2) make 3) sudo make install 4) sudo modprobe -rv rtl8723be 5) sudo modprobe -v rtl8723be ant_sel=2 6) sudo ip link set wlo1 up 7) sudo iw dev wlp13s0 scan

At no point i got any error. Tried with ant_sel=1 also.

Update:

Output of lshw -C network

siddharth@siddharth-HP-Notebook:~$ lshw -C network
WARNING: you should run this program as super-user.
  *-network                 
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 07
       serial: 30:e1:71:97:de:e0
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:16 ioport:4000(size=256) memory:b1200000-b1200fff memory:b1000000-b1003fff
  *-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlo1
       version: 00
       serial: 58:00:e3:a7:14:cb
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-33-generic firmware=N/A ip=192.168.43.59 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:17 ioport:3000(size=256) memory:b1100000-b1103fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user
0

I was able to solve it ultimately. Thanks to the last post by @pomsky.

My kernel version was 33-generic so i downgraded my kernel to 4.13.0-46-generic as it was the last available. And now wifi is working fine in Ubuntu 18.4.1 LTS.

I performed rest of the steps too, i.e upgrading to the latest rtlwifi_new and setting ant_sel=2. But at the end needed a kernel downgrade.

Thank you for your help

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.