0

I have installed kvm in ubuntu16.04 OS. WHen I am executing following command:

kvm-ok

I am getting following error:

INFO: /dev/kvm does not exist
HINT:   sudo modprobe kvm_intel
INFO: Your CPU supports KVM extensions
INFO: KVM (vmx) is disabled by your BIOS
HINT: Enter your BIOS setup and enable Virtualization Technology (VT),
  and then hard poweroff/poweron your system
KVM acceleration can NOT be used

This question already been asked : /dev/kvm is not found on Ubuntu 14.04

But, doesn't solved my issue. It was mentioned like I need change BIOS settings. If so, how can I change that in my ubuntu 16.04 OS?

  • Before installing "kvm", did you run egrep -c '(vmx|svm)' /proc/cpuinfo? Did you run kvm-ok (after installing cpu-checker? Did you get appropriate responses? – DK Bose Sep 6 '18 at 6:59
1

It has nothing to do with Ubuntu. You need to restart the computer and enter into your BIOS settings. How to enter and where to find this setting depends on your hardware, it is usually pressing F12 or Del or Ins during the hardware start, consult your hardware User's Guide

  • Hi @marosg, Thank you. Your solution helped me to solve the problem. – Shankar Muthu samy Sep 6 '18 at 13:50
0

Here is the solution as mentioned in above comment. I have followed the following steps:

  1. My Laptop in Lenovo. So anyone trying means find your laptop model in the following link: Hardware Model
  2. Shut down the system
  3. Hold Fn + F2 + Power Button
  4. Navigate to Configuration tab
  5. There we will see "Intel virtual technology" option
  6. Enable it
  7. Continue to boot the system
  8. Now, check for the command sudo kvm-ok. It will work.

Thanks for all who posted their solution and helped me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.