0

I'm on Ubuntu 18.04 with my Lenovo Thinkpad T460s. After an update a couple of weeks ago I did a reboot and I saw something which included the word "EFI" in the top left corner of my screen. Then everything went black and unresponsive.The laptop started system beeps every 5 seconds or so. I had no idea what was going on and tried to push the power button numerous times. I typed on the keyboard. Nothing. I was convinced something was terribly wrong. Nothing worked and since the laptop has a built in battery I could not cut power (probably a good thing in this case). After a couple of minutes the beeping stopped The laptop booted as normal. I had no idea what happened and whatever it was I was not given much forewarning or information. No way to see what it says while that message flashes by up in the screen corner.

I do know that a package with the word "firmware" in it was updated that day, but not exactly which one. I did check my bios and it's very new, from July 2018. I have not had Windows on this machine since I got it 18 months ago. I still wonder what this actually was. Anyone?

Update: I just read this about LVFS: https://www.omgubuntu.co.uk/2018/08/lvfs-lenovo-firmware-updates-linux

Could that be what I experienced?

2

A BIOS will never ever update itself and will only update when you tell it to do so. At the moment it requires a manual download, setting the download executable and follow the instructions for installing (sometimes you can load it from bios, others tell you to make a bootable medium).

Regarding the article: Lenovo is joining the Linux Vendor Firmware Service, better known as the LVFS. That is still in the future.

The laptop started system beeps every 5 seconds or so

Beeps are an indication of hardware failure. Here is a list of hardware errors for Lenovo. But you need to also remember if those beeps are short or long ;)

I do know that a package with the word "firmware" in it was updated that day

Most likely linux-firmware and that is "Firmware for Linux kernel drivers".

| improve this answer | |
  • Thank you for answers. I am still wondering why this is showing in my biois settings: "UEFI Bios Date (Year-Month-Day 2018-07-09"? I have not had Windows on this machine since I got it 18 months ago, and I have never attempted to update the bios. Could that date mean something else? – Christian Sep 11 '18 at 14:52
  • There was another bios update today which I installed. I still do not understand how it got installed back in August after I had installed Ubuntu 18.04. I didn't even know about LVFS until a couple of days ago. This is great news for Linux/Thinkpad (and other supported hardware) who, like me, do not dual boot. The update today had a Lenovo logo and progress bar but the same beeps. The one that happened back in August was just a black screen with beeps. – Christian Sep 20 '18 at 14:14
  • I have not seen any automated bios updates. Only kernel modules related to bios but that is not the same ;) So the question now is: did the version number or the date of your BIOS change? – Rinzwind Sep 20 '18 at 14:21
  • Yes it did change. It changed to v 1.37: is.gd/hWFrnb Last week it went to 1.39 but that one I downloaded from the LVFS site. The upgrade from the downloaded image happened in the exaxt same way, but this time it was a progress bar and Lenovo logo but the system beeps were the same. – Christian Sep 24 '18 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.