1

I was trying to setup a backup server with Ubuntu 18.04 Server

user@host:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:   bionic

but I ran into a dependency error even thou the dependencies that fail are installed.

user@host:~$ sudo apt-get install  amanda-server amanda-common  xinetd gawk gnuplot readline-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
readline-common is already the newest version (7.0-3).
gawk is already the newest version (1:4.1.4+dfsg-1build1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 amanda-common : Depends: adduser but it is not going to be installed
             Depends: debconf (>= 0.5) but it is not going to be installed or
                      debconf-2.0
             Depends: update-inetd but it is not going to be installed
             Depends: perl (>= 5.22.1-3) but it is not going to be installed
             Depends: perlapi-5.22.1
             Depends: libcurl3 (>= 7.16.2) but it is not going to be installed
 amanda-server : Depends: libcurl3 (>= 7.16.2) but it is not going to be installed
 cron : Depends: adduser but it is not going to be installed
        Depends: libpam-runtime (>= 1.0.1-11) but it is not going to be installed
 gnuplot : Depends: gnuplot5-qt but it is not going to be installed or
                gnuplot5-x11 but it is not going to be installed or
                gnuplot5-nox
 init-system-helpers : Depends: perl-base (>= 5.20.1-3) but it is not going to be installed
 libgd3 : Depends: libfontconfig1 (>= 2.11.94) but it is not going to be installed
 libpam0g : Depends: debconf (>= 0.5) but it is not going to be installed or
                 debconf-2.0
 libssl1.0.0 : Depends: debconf (>= 0.5) but it is not going to be installed or
                    debconf-2.0
 nginx-common : Depends: debconf (>= 0.5) but it is not going to be installed or
                     debconf-2.0
 python3 : PreDepends: python3-minimal (= 3.6.5-3ubuntu1) but it is not going to be installed
       Depends: python3.6 (>= 3.6.5-2~) but it is not going to be installed
       Depends: libpython3-stdlib (= 3.6.5-3ubuntu1) but it is not going to be installed
 python3-service-identity : Depends: python3-openssl but it is not going to be installed
 wireless-crda : Depends: crda (>= 1.1.1-1ubuntu2)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I did notice missing packages: update-inetd, perlapi, gnuplot5-qt. But I'm not sure if installing them will fix the missing dependency error on the installed packages too.

How can I install it on Ubuntu Server 18.04?

1
  • I found out the error. I had done a do-release-upgrade but the sources.list were not updated by this command. Using the correct sources.list should fix the problem.
    – Rafa He So
    Jan 18 '19 at 23:05