I currently only have Sun JDK7 installed on my system in regards to Java.

When I try to run a program (the Unix Runescape Client), here is what comes up in my terminal:

Trying to read /home/ryanmcclure/Programs/runescape/share/settings.conf Error reading settings.conf, using default value: 0 Error reading settings.conf, using default value: default-java Error reading settings.conf, using default value: 0 Error reading settings.conf, using default value: runescape.prm

Reading .prm file /home/ryanmcclure/Programs/runescape/share/runescape.prm This is the info i gathered from the runescape.prm file

## File Start

-Djava.class.path=jagexappletviewer.jar -Dsun.java2d.noddraw=true -Dcom.jagex.config=http://www.runescape.com/k=3/l=$(Language:0)/jav_config.ws -Xmx256m -Xss1m jagexappletviewer

## File End

I will now parse the parameters! Checking your client language setting(if any) Trying to read file /home/ryanmcclure/jagexappletviewer.preferences

Unable to read jagexappletviewer.preferences file, defaulting to Language=0 (English). I will now parse the contents from the jagexappletviewer.preferences file so it can be used. Stitching the language setting to the final parameters.

Final parameter string is: jagexappletviewer.jar -Dsun.java2d.noddraw=true -Dcom.jagex.config=http://www.runescape.com/k=3/l=0/jav_config.ws -Xmx256m -Xss1m jagexappletviewer

Launching client using this java version: sh: java: Permission denied

Launching the RuneScape Client using this command: cd /home/ryanmcclure/Programs/runescape/bin && java -cp
jagexappletviewer.jar -Dsun.java2d.noddraw=true -Dcom.jagex.config=http://www.runescape.com/k=3/l=0/jav_config.ws -Xmx256m -Xss1m jagexappletviewer /share

Executing the RuneScape Client! You are now in the hands of Jagex.

## End Of Script ## Jagex client output will appear below here

sh: java: Permission denied

What exactly does permission denied mean with Java? Please help!!!

  • have you tried starting it with sudo from the terminal? – Alvar Feb 24 '12 at 10:21
  • Yes, and it still yields the same result. I'm at a loss right now – Ryan McClure Feb 24 '12 at 10:32
  • the JDK is the developer package, you might need additional software to run it. Look in the Ubuntu Software Center. – Alvar Feb 24 '12 at 10:55
  • facepalm.png Wow, I'm an idiot. I'm removing JDK and am putting on JRE. Thank you...you saved me a world of confusion. – Ryan McClure Feb 24 '12 at 11:15
  • Still made no difference....Ugh, I really don't understand what could be wrong – Ryan McClure Feb 24 '12 at 11:44

for it to work you need to be able to use the command "java"
could you try adding the binary directly to settings.conf?
you can find the binary on any linux distro by using the command

sudo find / -name "libjli.so" | sed "s/\/lib\/\(i386\|amd64\)\/jli\/libjli.so/\/bin\/java/g"

example for the settings in settings.conf can be found inside settings.conf.example

  • Hi @Hikariknight! You helped me with this a while back, but I never put this as the answer here on AU. :) – Ryan McClure Jun 5 '12 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.