4

I've installed an Ubuntu 18.04. When I try to reformatting code shortcut in PyCharm - CTRL+SHIFT+L, Ubuntu raises something - Mate-settings-daemon "" is ready or before:

enter image description here

I suppose it's because this Ubuntu uses this shortcut too but I don't know how to disable it.

I tried to find it in Keyboard shortcuts, but it isn't there.

Do you know how to make it work so I can use this shortcut in PyCharm?

enter image description here

| improve this question | | | | |
  • Do you have the mate desktop environment and gnome shell ? – Jerare Sep 5 '18 at 13:02
  • Not sure, it should be official Ubuntu 18.04... – Milano Sep 5 '18 at 13:03
  • did you not install another desktop environment (graphical user interface) than the default one? Mate-settings-daemon is for the Mate desktop and it can't be change in gnome shell – Jerare Sep 5 '18 at 13:09
  • No I didn't. But I've edited a question and added a new screenshot. This is the window which pop ups when I press ctrl alt l – Milano Sep 5 '18 at 13:21
1

I had the same problem, and managed to fix it through dconf editor. Just did a search for "screensaver", and found the following property with ctrl + alt + l as a shortcut: /org/cinnamon/desktop/keybindings/media-keys/screensaver. Removed the shortcut, and tried reloading Gnome, without effect. After a reboot it worked though, maybe a relogin would do the trick as well.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.