2

I have a new installation of Ubuntu 18.04 dual boot with Windows 8.1, with (GNOME) Tweaks installed, I need compose key to type Brazilian accent words (à á ã ç), so I installed Tweaks, "US intl with dead key" keyboard layout and followed the instructions on this post. I don't have Scroll Lock, so I tried with PrtScn & right-Alt, none of them worked.

This is the key sequence, compose key (PrtScn or right-Alt) + ' + c, did not work, changed the sequence to compose key (PrtScn or right-Alt) + c + ' both gave me c.

Am I missing some steps?

  • What happens if you simply press <right-alt>+<,> (comma) and <right-alt>+<shift>+<,>? – pomsky Sep 5 '18 at 10:51
  • Compose Key disabled, <right-alt>+<,> (comma) = ç, and <right-alt>+<shift>+<,> = Ç, with Compose Key enabled to Right Alt, <right-alt>+<,> (comma) = (blank), and <right-alt>+<shift>+<,> = < – Michael Sep 5 '18 at 11:14
2

You don't need to use the "US international with dead keys" layout if you're using the compose key. Simply use the standard US layout.


With the "US international with dead keys" layout, you can get some of those special characters without enabling the compose key simply by using the "level 3 select key" (level 3 select key is usually AltGr aka right-Alt key). See the layout:

enter image description here

For example,

  • AltGr+, (comma) gives "ç" and AltGr+Shift+, gives "Ç"
  • AltGr+A gives "á" and AltGr+Shift+A gives "Á"
| improve this answer | |
  • great, thanks so much for your detailed explanation. – Michael Sep 6 '18 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.