3
  1. Problem(s):

    • The subwoofer does not work on Lenovo Y720 on Ubuntu 18.04, so I have changed some pins in HDAJackRetask. I tried over 30 combinations, most of them gave me the same output, so here is what I found the best output with the most settings.

enter image description here

  1. What information I have collected from HDAJackRetask:

    • LFE and surround are two new settings which i did not have before. The problem is however, that they don't seem to do anything, I can't even adjust the LFE as it has no slider and the surround adjustment does no effect at all.
    • In the screenshot there is also the pin "0x14" which is the internal speaker. If I override that to "Internal speaker (LFE)" or "Internal speaker (Back)" I will suddenly get a lot more sound profiles in the Ubuntu settings, 2.1, 4.0, 5.0, 5.1 etc. but no matter what I choose it will result in no sound at all, so I stopped overriding that.
    • With the HDAJackRetask configuration above, I get two profiles in the Ubuntu sound settings. One called "Analog Stereo Output" (which is my standard) and "Analog Surroind 4.0 Output". Both works.
    • After reading several posts about this problem and tracking the bug on launchpad, it seems that 0x17 is the subwoofer, but turning it on still does nothing.
  2. List of everything I have tried:

    • HDAJackRetask: With the description above.

    • Ubuntu settings: On a fresh install there is only one kind of ouput speakers, which is analog built in, so there is nothing to look up in settings.

    • File changes: I added: load-module module-combine channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe at the end of /etc/pulse/default.pa and edited a line in /etc/pulse/daemon.conf from "enable-lfe-remixing: no" to "enable-lfe-remixing: yes". Please note that by doing this I actually got a subwoofer sound setting under settings, but it does not do anything, there is no difference in sound when it's on or off.

    • GitHub Lenovo Y50 script: https://github.com/dragosprju/y50-subwoofer-linux-enabler without any luck too.

    • HDA Analyzer: I tried disabling power saver on the pins, look here for more: Lenovo Y50 Subwoofer does no work with Ubuntu 14.04.2 LTS

  3. The bug can be found at: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1553685

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy