I am new to ubuntu so please keep that in mind.

I installed ubuntu 18.04 LTS on my Thinkpad L540. Most often my mouse cursor, if I use my touchpad, is laggy/choppy in a visual way. This does not happen if I use an external mouse (bluetooth). Everything else is working fine (fluid/without lags). After some reboots, it sometimes works.

I take the notebook with me and I often cant use a bluetooth mouse, so I am stuck with rebooting my device as many times as it takes, to get it working.

Did not happen on Windows 10. That is my first try installing Linux on this notebook.

I presume that my touchpad device is a SynPS/2 Synaptics TouchPad (Terminal: xinput).

Any advice on what I can do or check to get rid of this problem?

  • Can you clarify if the lagginess is always present no matter what speed you move the pointer, or only if you are moving the pointer slowly?
    – Michael
    Commented May 4, 2019 at 1:43
  • 1
    @Michael I installed Manjaro and dont suffer from this issue anymore. But the problem was consisten (didnt matter if i moved slow or fast). Thanks for asking tho :D
    – ernst
    Commented May 5, 2019 at 15:12

5 Answers 5


see my answer here:

I can confirm a similar issue with my touchpad on HP ProBook 450 G6 with Ubuntu 18.04, it was very laggy after suspend.

What worked for me: create /lib/systemd/system-sleep/touchpad:


case $1 in
    /sbin/rmmod i2c_hid && /sbin/modprobe i2c_hid 

make file executable chmod +x /lib/systemd/system-sleep/touchpad and test (suspend computer and wake-up again)

  • 2
    I have an HP Probook 440 G6, with Ubuntu 18.04, and this worked for me. Thanks!
    – noname
    Commented Sep 4, 2019 at 17:18

I had this (or a similar) problem with a thinkpad 470. The mouse pointer was suddenly choppy after a reboot. Rebooting did not help.

The problem finally went away after I sent it to sleep and woke it up again. (sudo systemctl suspend)


I have same problem on my Thinkpad T460s with Ubuntu 18.04 (Ubuntu 16.04 and Windows 10 have no problem). I tried the solution here and after reboot, the problem was solved.

sudo apt install xserver-xorg-input-synaptics-hwe-18.04

I am using a Lenovo T470, I encountered the same problem. I updated to version 19.04 but nothing changed. Then I disabled the Trackpoint in the Bios settings. My Touchpad doesn't make any more problems since.

  • 1
    I also had the problem on a T470 and disabling the track point didn't help Commented Feb 1, 2020 at 1:45

I had a similar problem on my Thinkpad with Ubuntu 18.04. The cursor was very jumpy. It seems to be a problem with the version of the touchpad driver used in Ubuntu 18.04, "libinput". I read somewhere (can't find the link, sorry) that it's fixed in newer versions of the driver which are going to be released for Ubuntu 18.10. Whether it's going to be released for 18.04 as well it was said there is not clear by now.

For me installing the synaptic driver instead of libinput solved my problem: https://ubuntuforums.org/showthread.php?t=2391805 https://bugs.launchpad.net/ubuntu/+source/libinput/+bug/1696929

  • I have a much worse version of this problem, even after installing xserver-xorg-input-synaptics: the mouse cursor moves/clicks only about 5% of the time I use the Touchpad. I've left comment #28 on that bug. Commented Dec 9, 2018 at 5:42
  • I am using 18.10 and this problem still there
    – Lekr0
    Commented Mar 16, 2019 at 14:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .