While upgrading from Xenial to Bionic on a VPS server based on a 64bit, I get the following error:

Could not install the upgrades    
The upgrade has aborted. Your system could be in an unusable state. 
A recovery will run now (dpkg --configure -a).

dpkg: dependency problems prevent configuration of libc-bin:
 libc-bin depends on libc6 (>> 2.27); however:
  Version of libc6:amd64 on system is 2.23-0ubuntu10.

dpkg: error processing package libc-bin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

Upgrade incomplete  
The upgrade has partially completed but there were errors during the
upgrade process.

I tried almost everything I could google but nothing works:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc6 : Breaks: libc6:i386 (!= 2.27-3ubuntu1) but 2.23-0ubuntu10 is to be installed
 libc6:i386 : Breaks: libc6 (!= 2.23-0ubuntu10) but 2.27-3ubuntu1 is to be installed
 libc6-amd64:i386 : Depends: libc6:i386 (= 2.27-3ubuntu1) but 2.23-0ubuntu10 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

If I try apt-get -f install I get :

 Configuring libc6 tqqqqqqqqqqqqqqqqqqqqqqqqqk
   x                                                                       x
   x Kernel must be upgraded                                               x
   x                                                                       x
   x This version of the GNU libc requires kernel version 3.2 or later.    x
   x Please upgrade your kernel before installing glibc.                   x
   x                                                                       x
   x                                <Ok>                                   x
   x                                                                       x

And i´m in a loop.

Is there any solution to this failed upgrade?

  • 1
    I have this problem too. Sep 24, 2018 at 13:23
  • 3
    I belive this is a OpenVZ issue when OS templates are old. I was on a cheap VPS server with old OS templates that dont suport a recent kernel. I don´t know how to solve that without changing to a new hosting company. Sep 25, 2018 at 14:22


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.