0

I have installed a windows application using wine and I tried to create a text file on desktop containing the following line:

wine ".wine/drive_c/Program Files/app1/app2018/app.exe"

then I saved the file as a .sh file and I made the file executable to be able to open this application directly by double clicking the text file, but it didn't work.

Note that when I write the same line in terminal the application opens directly with no problems.

Any ideas please?

  • Welcome to AskUbuntu! Did you include the shebang on the script? – Helio Sep 4 '18 at 14:06
  • I didn't include the Shebang on the script. I just wrote the line in the text editor and saved as .sh then made executable – Ahmed Razeen Sep 4 '18 at 14:08
  • 1
    You need to include the shebang (#!/bin/bash) on the very first line of the script so it can run correctly. – Helio Sep 4 '18 at 14:09
  • I added it now but it also didn't work for me. I tried now also to add 'sudo' before my line to help open and opened in terminal but it also didn't work. – Ahmed Razeen Sep 4 '18 at 14:13
  • Yes, this was right. I actually found a duplication. Thank you very much – Ahmed Razeen Sep 4 '18 at 14:17

Browse other questions tagged or ask your own question.