2

I'm using Kubuntu 18.04.1 on a System76 laptop using Xorg and there is a keyboard shortcut that I can't get rid of. ALT and any of the function keys switches the virtual tty (instead of ctrl-alt-F# like I'm used to). This conflicts with common shortcuts I use such as Alt-F4 to close a window. Furthermore, ALT- will switch to a different tty (which conflicts with the BACK shortcut I use when browsing the web).

I've checked the (many) plasma keyboard shortcut settings and couldn't find anything (in fact, Alt-F4 is bound to close windows in kwin). I found this question: How to config hotkeys for switching between consoles in ubuntu and that let me enable using Ctrl-Alt-F# to switch TTYs, but the ALT-F# keybinding persists. The same keystrokes work in the other virtual consoles where X isn't running, so I think this isn't a KDE/Plasma issue, but I don't know.

5

Credit for the answer goes to DK Bose who linked the answer by none other than Alan Pope here: https://askubuntu.com/a/929115/248158. But for completeness, I'm putting the answer here as well. The keyboard was set to unicode mode, and by setting it to raw mode, these key sequences were then interpreted as expected.

sudo kbd_mode -s

This is persistent across reboots. And to restore it to how it was before:

sudo kbd_mode -u
  • Life saver, thank you! After random update this fuckitx (fcitx) installed itself and took over this ALT+F1, ALT+cursor keys switching. Finally could get rid of that UX nightmare. – dusoft Apr 18 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.