0

So, last night, when shutting down the laptop, there was a prompt to install updates and then poweroff so I did that. Next thing I know, when I boot my laptop, I get the grub rescue prompt. Here's what I know so far:

grub rescue> set

cmdpath=(hd0,gpt1)/EFI/ubuntu

prefix=(hd0,gpt3)/boot/grub

root=hd0,gpt3

I tried to do:

linux /boot/grub/vmlinuz-4.15.0-34-generic root=/dev/sda3

and I get:

Unknown command `linux'.

I've also tried to:

insmod /boot/grub/x86_64-efi/linux.mod

but I have not had any luck loading linux. I can't do normal.mod either nor boot. I'm stuck here and need some help on how to boot so I can do grub-install. There's no other OS on the laptop and my home directory is in a different partition, for what its worth. Please help me recover my Ubuntu.

  • what is the output of insmod /boot/grub/x86_64-efi/linux.mod? – j-money Sep 3 '18 at 22:50
  • There is no output. It's as if it went through without problems. I still get Unknown command afterwards. – user285112 Sep 4 '18 at 5:46
0

My problem has been resolved. I loaded a live USB session of Ubuntu 18.04 and installed the Boot Repair.

https://help.ubuntu.com/community/Boot-Repair

Using the Recommended repair option reinstalled grub with the shim.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.