2

after some update approximately a year ago, my wi-fi became hard-blocked. I've tried countless tutorials solving similar problem but nothing has helped me, so I'm finally desperate enough to ask by myself. I have HP Pavilion with Ubuntu 16.04 and my network controller is

Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
  • Hardware button only changes if the wi-fi is soft-blocked. (edit: now my hardwave switch doesn't change anything)
  • rfkill unblock all doesn't work.
  • sudo ifconfig RT3290 up tells me, that this module is not found (I've tried even different versions of name, but it's possible, that I'm just not able to find a right name of my controller)

Most of my attempts was like a six months ago, so I don't even remember what I've tried. With Windows (I have dual-boot), wifi is working ok.

Can you please help me?

Edit 7.9.: I've reinstalled Ubuntu and it's still not working. Wifi is hard-blocked, flight mode is on and I can't turn it off, because hardware switch doesn't work (only in Ubuntu. In Windows, wifi and hardware switch are ok)

0

I face the same issues and use the following 3 commands to fix it.

sudo systemctl restart network-manager.service 
sudo ifconfig wlan0 up
sudo rfkill unblock all

I dont remember where I found it as I have been using these commands for a while. Let me know it helps or if you have any queries.

  • Do I have to change 'wlan0' with something? Because result with this was 'wlan0: ERROR while getting interface flags: No such device' – Zuikaku Sep 4 '18 at 7:50
  • Yes. Can you post the output for 'iwconfig'. You will have to select your own wifi using this – user2849789 Sep 5 '18 at 3:38
  • Output for 'iwconfig': lo no wireless extensions. eno1 no wireless extensions. wlo1 IEEE 802.11 ESSID:off/any Mode:Managed Access Point: Not-Associated Tx-Power=off Retry short long limit:2 RTS thr:off Fragment thr:off Power Management:off – Zuikaku Sep 5 '18 at 7:17
  • With 'sudo ifconfig wlo1 up' I got 'SIOCSIFFLAGS: Operation not possible due to RF-kill' – Zuikaku Sep 5 '18 at 7:21
0

Few days back i face the same issue with my Toshiba satellite laptop,what i found the solution is I just remove my battery and replug it and restart after that the problem get solve. It works for my laptop try for your but I don't give guarantee of that.

  • Thank you! My hardware switch is now OK, but sadly it again only changes if the wifi is soft-blocked - so wifi is still disabled/ hard-blocked. – Zuikaku Sep 7 '18 at 20:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.