2

After upgrading from Ubuntu 16.04 to 18.04 my USB 3.0 Hub stopped working. When i plug in the hub dmesg gives:

$ dmesg
[  481.971312] usb 3-1: USB disconnect, device number 2
[  481.979323] usb 4-1: USB disconnect, device number 2
[  493.939188] usb 4-1: new SuperSpeed USB device number 3 using xhci_hcd
[  494.198398] usb 4-1: New USB device found, idVendor=2109, idProduct=0812
[  494.198401] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  494.198404] usb 4-1: Product: USB3.0 Hub
[  494.198406] usb 4-1: Manufacturer: VIA Labs, Inc.
[  494.199715] hub 4-1:1.0: USB hub found
[  494.199873] hub 4-1:1.0: 4 ports detected
[  494.322958] usb 3-1: new high-speed USB device number 3 using xhci_hcd
[  494.473191] usb 3-1: New USB device found, idVendor=2109, idProduct=2812
[  494.473194] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  494.473197] usb 3-1: Product: USB2.0 Hub
[  494.473199] usb 3-1: Manufacturer: VIA Labs, Inc.
[  494.473726] hub 3-1:1.0: USB hub found
[  494.474125] hub 3-1:1.0: 4 ports detected

When I plug in a USB-Stick, to the hub, nothing changes, but the Hub-Status led gives signal, that the Stick is working. When i plug in the Stick directly it is working.

I already tried to boot first and than connect the hub, with the same result.


Edit 14.09.18 21:50:

When I boot with USB-Stick pluged in the Hub works. When I boot without USB-Stick pluged in it doesent work.


Edit 15.09.18 14:30:

The Hub works, when it is connected to the PC with a device connected to the Hub. If the hub is connected to the PC without a Device connected to the hub it wont work.

Here the dmesg with device connected to the hub:

$ dmesg
[15631.321363] usb 3-1: USB disconnect, device number 2
[15631.325379] usb 4-1: USB disconnect, device number 2
[15635.397384] usb 4-1: new SuperSpeed USB device number 3 using xhci_hcd
[15635.656658] usb 4-1: New USB device found, idVendor=2109, idProduct=0812
[15635.656662] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[15635.656664] usb 4-1: Product: USB3.0 Hub             
[15635.656666] usb 4-1: Manufacturer: VIA Labs, Inc.         
[15635.658178] hub 4-1:1.0: USB hub found
[15635.658302] hub 4-1:1.0: 4 ports detected
[15635.781248] usb 3-1: new high-speed USB device number 3 using xhci_hcd
[15635.930894] usb 3-1: New USB device found, idVendor=2109, idProduct=2812
[15635.930898] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[15635.930900] usb 3-1: Product: USB2.0 Hub             
[15635.930902] usb 3-1: Manufacturer: VIA Labs, Inc.         
[15635.931423] hub 3-1:1.0: USB hub found
[15635.931786] hub 3-1:1.0: 4 ports detected
[15636.045277] usb 4-1.1: new SuperSpeed USB device number 4 using xhci_hcd
[15636.066028] usb 4-1.1: New USB device found, idVendor=0781, idProduct=5580
[15636.066031] usb 4-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[15636.066034] usb 4-1.1: Product: Extreme
[15636.066036] usb 4-1.1: Manufacturer: SanDisk
[15636.066038] usb 4-1.1: SerialNumber: AA010301151733012970
[15636.085093] usb-storage 4-1.1:1.0: USB Mass Storage device detected
[15636.085206] scsi host6: usb-storage 4-1.1:1.0
[15636.085312] usbcore: registered new interface driver usb-storage
[15636.091297] usbcore: registered new interface driver uas
[15637.097724] scsi 6:0:0:0: Direct-Access     SanDisk  Extreme          0001 PQ: 0 ANSI: 6
[15637.098312] sd 6:0:0:0: Attached scsi generic sg4 type 0
[15637.098575] sd 6:0:0:0: [sdd] 122544516 512-byte logical blocks: (62.7 GB/58.4 GiB)
[15637.098821] sd 6:0:0:0: [sdd] Write Protect is off
[15637.098825] sd 6:0:0:0: [sdd] Mode Sense: 53 00 00 08
[15637.099029] sd 6:0:0:0: [sdd] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[15637.106686]  sdd: sdd1
[15637.107824] sd 6:0:0:0: [sdd] Attached SCSI removable disk
  • Workaround: Have always a device connected to the USB-hub – Rexaris Sep 15 '18 at 12:39
  • same here. could you manage to solve this problem ? – oguz ismail Oct 15 '18 at 17:30
  • no i currently use my workaround. – Rexaris Oct 16 '18 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.