I'm a newbie to Linux and tried to install Ubuntu 18.04.1 LTS Desktop (link). I had 25.1 GB of free disk on C Drive and followed this tutorial to install it with my USB drive.

After entering the Boot screen on my laptop and choosing "UEFI" -> Install Ubuntu, this screen appeared. I spent the whole night waiting for it to load, but after 8 hours nothing happened.

I've tried searching the internet but didn't see a solution that actually works on my laptop. I turned it off and turned it on with Windows 10, and saw that C drive only has 17.7 GB free disk now.

PC information Graphic card: NVidia 1050 Ti.

Edit 1: [ESC] when loading: screenshot, screenshot

  • 1
    If you have nVidia, you need nomodeset boot option for both installer and first boot or until you install nVidia driver from Ubuntu (not from nVidia). Make sure fast start up is off in Windows (note that Windows updates will turn it back on). Ubuntu cannot see your NTFS partitions if hibernated. askubuntu.com/questions/843153/… & askubuntu.com/questions/221835/…
    – oldfred
    Sep 3, 2018 at 18:45
  • @oldfred thank you for your kind help! But I can't understand very well and don't know what exactly to do after reading the two posts. I have attached screenshots in my edit. Can you explain further?
    – Tian Shuo
    Sep 3, 2018 at 19:12
  • Are you booting live installer in UEFI mode? Then you manually add in grub menu ( e for edit) nomodeset to linux line in place of quiet splash parameters. If that is still an issue then additional parameters may be required. But I still get the AE_ type errors & system works fine.
    – oldfred
    Sep 3, 2018 at 19:36
  • @oldfred yes I am using UEFI. Being a complete noob, I don't understand what the rest means. How do I "manually add in grub" and do everything else?
    – Tian Shuo
    Sep 3, 2018 at 19:38
  • The delay/freeze is probably the installer looking for other partitions and a fast start/hibernation in Windows prevents it from seeing it, and stops. Skip the BIOS boot screen examples and see the UEFI with grub examples. askubuntu.com/questions/162075/…
    – oldfred
    Sep 3, 2018 at 21:30

1 Answer 1


You get it wrong about installing Ubuntu at all! you can't install Ubuntu in that way, however your problem is not related to installation progress, but to booting it from your CD (or any other similar devices like USB).

Please try again, but when you see this loading page, please use esc key on your keyboard, now you can see a black terminal with white lines. It will freeze on some level of loading (probably loading kernel modules related to your graphic card). Just attach that screen, so we can see what is your main problem...

  • Edited. Can you please check?
    – Tian Shuo
    Sep 3, 2018 at 19:09
  • Based on your monitors frame, you have same laptop to me :) MSI GE63 or similar model. MSI has too much problem with Linux Kernels all the time. If you try the MSI Support center, they will just give you: We recommended windows... Anyway, I was right about modules! for booting the Ubuntu you need to disable your acpi from boot record. really I don't remember how we could edit load parameters when we loading from external devices (I do it mostly with grub2) but in your case it is not suitable way to fix it. Sep 3, 2018 at 19:14
  • There is no easy way for you as much as I know. sorry man. Maybe others can help you for adding acpi=off flag on booting the OS from external device... Sep 3, 2018 at 19:16
  • This is an HP Omen laptop, not MSI :-). Still, thank you for your help.
    – Tian Shuo
    Sep 3, 2018 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .