0

I had PCie_bus_error error message flooding the screen every time I tried to turn off my laptop. I watched this video and applied changes to my etc/default/grub, I did this

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

then I did

sudo update-grub

and hoped the error will be corrected and if not I will apply the other method to it i.e. "pci=noaer" but the ubuntu is stuck after initial loading at link to the stuck screen image, after long wait I have to turn off the laptop using the power button. I have also tried updating the

GRUB_CMDLINE_LINUX_DEFAULT with pci=noaer using "grub-> recovery-> resume".

Please help me with this, thanks. Other details: installed ubuntu 18.04LTS Laptop: asus

Edit: I think there's something wrong with my log files they have taken a whole lot space as I can see in recovery mode

79041M kern.log, 13508M kern.log.1, 61355M syslog, 17688M syslog.1,

the kern.log file is filled with that same PCie port error discussed above.

  • Have you tried adding a ' 1 ' to your 'linux' kernel line; so it will boot into single (1) or maintenance/recovery mode. At grub select <E> (for edit), then make change and use <F10> to boot. It may allow you to get to terminal (gui is disabled) I'd also suggest removing 'quiet splash' as quiet reduces messages (for diagnosis you want as much messages as possible) and you don't need the splash screen hiding boot messages when you have problems... – guiverc Sep 3 '18 at 8:38
  • screen has gone blank after removing quiet splash and adding 1 to the line in grub. – Onix Sep 3 '18 at 16:39
  • instead after adding just 1 to the 'linux line' and not removing the quiet splash line, I got the rescue mode with root@user console what should i do now?? – Onix Sep 3 '18 at 16:45
  • My intention was to put a ' 1 ' as a param instead of 'quiet splash' (my language could have been better I acknowledge) so you saw more messages (that may provide more clue; though you'd have to read quick), and could login to 'rescue' mode, to make the 'next' change you wanted to try.... – guiverc Sep 3 '18 at 23:43
  • I briefly looked at the lp.bug you listed, it was for 16.04 with fix released so shouldn't affect you anyway (even if messages look the same, is your software updated?); though after that I noted lots of reports & differing opinions on possible causes (many pointing to bios or hardware specific timing bugs). You didn't provide your actual error message, so I didn't try a search beyond the fixed lp.bug... – guiverc Sep 3 '18 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.