I was trying to upgrade my Lubuntu 17.10 to Lubuntu 18.04.

The first time I tried with the Gui(Software & updates) which said me that had to download ~862 MB (if I'm not wrong) but during fetching files at the end (1473/1474) a friend of me for a joke clicked on cancel, a message popped up saying that If I want I can restart the upgrade of Lubuntu later by reopening the Gui. I tried and this time it shown that it could not download ~862 MB but only ~62 MB and I tried upgrading anyway but then It complitly stopped working during the fetching. I waited for 4hours nothing happened.

Tried to close the upgrade by cancelling everything was freezed and I was forced to shutdown forcibly. Restarted the pc, I tried via LXterminal to look with lsb_release -a, and saw lubuntu 17.10 Then used sudo apt update && sudo apt dist-upgrade than checked if I had 'update-manager-core' with 'sudo apt install update-manager-core' and said that it was damaged, and asked if it had to fix, answered yes, I checked againg and everything seeemed ok. I used do-upgrade-release and the next morning (8 hours later I saw that it was shutted down.

I tried boot and a 'initframes' shall appared displaying an error of the folder '/dev/sda1' in some systemfiles and said to fix them manually by using fsck. I used 'fsck /dev/sda1' and than said the 98% of files were fixed. After restart I saw all the icons missing, even if I could start application or navigate in internet, but when I checked the version, I saw 'Ubuntu 18.04.1 LTS' with codename bionic.

Please I need help.

  • 1
    Welcome to Ask Ubuntu. Hopefully you'll get better advice than this, but if it was me, I'd ensure my files were backed up (you'd have done this before you started the do-release-upgrade anyway), fsck again from live system, check it really is 18.04 (maybe even try do-release-upgrade again as it'll do nothing if you are on 18.04), then re-install using the 18.04 LTS lubuntu ISO. I'm not suggesting a clean install, I'd use 'something else' & not format; it'll erase your program directories, but will attempt to reload the programs at the end of install anyway. This is a suggestion only.
    – guiverc
    Sep 2 '18 at 8:04

At the end I found a really easy way to fix my problem. I started the terminal and runned 'sudo apt full-upgrade' and then 'sudo apt autoremove', I rebooted and saw everything perfect, only the network manager applet missing (it seems an old bug)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.