2

I installed X11VNC server on a Zotac ZBox PI133 running Ubuntu mate 18.04.1 and all seemed fine, except when I connect to this VNC Server from my MacBoo, the connection drops after 2 or 3 minutes. I can connect to other VNC servers running under Lubuntu 16.04 without an issue. Is there a known bug with 18.04 that causes this error?

1

Ok, this is an attempt at an actual answer. I have tried two different VNC clients. An older version of Real VNC, and a newer version of Real VNC. The older version experiences regular disconnects to an Ubuntu MATE 18.04 box running X11VNC, but (so far) the newer version of Real VNC does not disconnect.

The Old version was Real VNC Viewer 5.1.0 (64 bit), running on Windows 8.1 Pro The New version is Real VNC Viewer 6.17.1113 (64 bit), running on Windows 8.1 Pro

It may be that there is some difference in the default settings between the old and new versions that behaves differently with whatever has changed on Ubuntu's X11VNC, but I haven't identified which setting (encryption method maybe???).

What I do know is that the old VNC version worked perfectly with Ubuntu 16.04 LTS (with MATE desktop), and became highly unreliable with Ubuntu 18.04 LTS (with MATE desktop)

I would recommend using this new version of Real VNC viewer as your solution. Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.