0

I successfully dual boot ubuntu 16.04(LTS) with Windows 10 OS on my Dell XPS 9350 using videos on YouTube. During the process, it was required to

  1. disable the Windows Secure-boot option
  2. boot in SAFEMODE."SystemConfiguration--> safe boot--> Minimal"
  3. Change SATA operations from RAID to AHCI.

Now if I am using Windows, In the safe mode, I can't work as I was before. The problems are

  1. Applications such as IntelliJ(an IDE) doesn't start from the start menu.
  2. The hibernate option has gone.
  3. Application cannot detect the audio drivers.

Could any suggest that Is it safe to resume the Normal boot mode.? FYI, a few screenshots. enter image description here

enter image description here

enter image description here

Also, I tried changing to Normal boot mode by changing MSConfig as Normal settings.

Since then Windows works perfectly fine, but now I didn't get an option booting laptop for Windows Manager & Ubuntu. Instead, Windows directly gets started.

One solution I tried, In this situation, Whenever, I start my system, I need to press F12 and select UBUNTU, then it redirects me to GRUB loader and then I can select whichever OS I wanna use(and I don't have to start windows in safe mode anymore.).

enter image description here

enter image description here

Could anyone help what's happening and how to get

  1. normal windows execution.
  2. Both Windows & Ubuntu as an option upon booting the laptop without pressing F12.
3
  • 1
    This might help askubuntu.com/a/493600/816190 I have experienced some lags and divert installation problems after enabling secure boot. So, I think disabling secure boot in dual boot environment is what to be done.
    – Kulfy
    Sep 1 '18 at 19:01
  • @kulfy, There were no issues while installing Ubuntu alongside Windows. The Issue is if I boot windows from SAFE BOOT to NORMAL BOOT, then at the time of booting the machine, the grub loader disappears. I need to press F12, then select Ubuntu to get the grub loader. Else, it always starts with windows.
    – Anu
    Sep 1 '18 at 20:19
  • Unless you have a problem that can no be resolved leave it enabled.
    – Panther
    Sep 2 '18 at 2:33
0

This may not be the answer (but I am not able to just 'comment').

Have you switched Windows into 'Fastboot' mode ? That is a misleading name because it really means just hibernate so when you restart the machine you will not get a bootloader menu but simply restart Windows.

I inadvertently did this after installing linux onto a Windows 7 (or 8) machine and ot gave me the same symptoms that you have; it proved non-trivial to revert to the bootloader, or at least it tool a while to understand the problem, and I think that after I corrected Windows I just reinstalled linux.

graham

1
  • UEFI has fast boot setting, and Windows has fast start up setting. UEFI fast start up can be so fast that you do not have time to press f12 or f2 to get into UEFI. And Windows fast start is hibernation and prevents Ubuntu's NTFS driver from seeing the NTFS partitions. askubuntu.com/questions/843153/… & askubuntu.com/questions/145902/… If you need proprietary drivers for video or Wi-Fi you need to turn off UEFI Secure boot, but need signed kernels & grub.
    – oldfred
    Sep 2 '18 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.