Could any one tell me why there is a conflict in this package? and how do I resolve it?. Thanks.

Synaptic Package Manager

UPDATE: it is not broken, but there is a conflict that it cannot be installed. The dependency is as the following: lllvm-dev -> llvm6.0-dev -> libtinfo-dev

The following packages have unmet dependencies:
libtinfo-dev : Depends: libtinfo5 (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is to be installed
E: Unable to correct problems, you have held broken packages.

enter image description here

  • 1
    You created a version conflict. You told the system to install two packages, each of which depends upon a different version of some dependency. The most common reason is that the user added a non-Ubuntu or wrong-release source that provided an incompatible version of the software. – user535733 Aug 31 '18 at 21:10

I follow the answer for this question, and install aptitude. It allows me to downgrade libtinfo5, which fixes the dependency. This is actually great, I'm surprised aptitude has not been as popular as apt-get (at least for me.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.