2

So I installed Ubuntu 18.04.1 LTS onto my laptop a few days ago and have run into a strange problem. If I shut the lid on my laptop and allow the computer to go into sleep mode, when I try to use it next it will go back into sleep mode about every 30 seconds. The only way I have found to fix it so far is to do a hard restart.

I also tried changing settings in /etc/systemd/logind.conf to:

 HandleLidSwitch=ignore

Any suggestions on what to do?

dmesg log before shutting lid:

[    1.063558] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:19/PNP0C09:01/PNP0C0D:00/input/input0
[    1.063567] ACPI: Lid Switch [LID0]

dmesg log after shutting lid:

[    1.063558] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:19/PNP0C09:01/PNP0C0D:00/input/input0
[    1.063567] ACPI: Lid Switch [LID0]
[ 3862.929353] ACPI: button: The lid device is not compliant to SW_LID.

Hardware: - 2017 Razer Blade - Ubuntu 18.04.1 LTS

edit 1: Leaving the lid open and letting the laptop sleep does not lead to this problem

edit 2: I've found that setting

HandleSuspendKey=ignore

fixes the issue

2
  • Welcome to AskUbuntu! Please add logs from dmesg starting from the time you close the lid of the laptop. You can edit and update your question to include the additiona info. Also include some details about the machine hardware and setup. That will greatly help in trying to figuring out what is goind on. Aug 31, 2018 at 17:53
  • Thank you! For me I only had to do "HandleLidSwitch=ignore", but this fixed the issue I was having with my Razer Blade 14". Running "sudo systemctl restart systemd-logind" fixed it on the spot. Oct 18, 2019 at 2:15

1 Answer 1

0

My colleges and I were having the same issue on the Lambda Labs Tensorbook made by Razor running Ubuntu 20.04.4 LTS.

This issue has been addressed here: https://help.ubuntu.com/community/RazerBlade

The OS does not detect that the lid has been opened if the laptop is suspended. This can be fixed through the following modification:

Edit the default grub config:

sudo nano /etc/default/grub

Add button.lid_init_state=open to the end of the GRUB_CMDLINE_LINUX_DEFAULT option, like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash button.lid_init_state=open"

Run the following command to update grub once you are done:

sudo update-grub 
sudo reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .