0

This question already has an answer here:

I've searched around and not found anything quite like the issue I'm having.

I have Windows 10 on an NVME drive and I want to install Ubuntu to a second SSD on the same system.

I tried earlier and went through the basic install and it seemed successful - the machine booted to Ubuntu.

I was expecting the GRUB menu screen and I didn't get it.

Am I doing something wrong?

Should I install ubuntu manually?

If I set a timer to -1 on in /etc/default/grub then the GRUB menu will show up but still Windows 10 is not listed.

If I hit esc on launch I get a grub> command interface, and by typing exit I get into Windows.

I should note that my main display is 1440 and the Ubuntu install defaults to my 1080 display. Could that be an issue? Can't think it would be since GRUB doesn't care.

How can I get the GRUB menu to appear on boot with options for Windows 10 and Ubuntu?

marked as duplicate by karel, N0rbert, Thomas, Charles Green, Fabby Sep 2 '18 at 12:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Are both installed in UEFI boot mode? Your boot into Windows seems like a reboot into UEFI. And when both are not UEFI or both BIOS, you can only dual boot from UEFI boot menu. Post link to Summary Report: help.ubuntu.com/community/Boot-Repair – oldfred Aug 31 '18 at 15:19
  • Windows 10 is installed in UEFI mode. I have fast boot disabled. I created a live usb with ubuntu but i cannot set it to UEFI mode.? – Sudo Aug 31 '18 at 20:41
0
  • Check if the Fast Startup option is disabled in Windows, if it is disabled you can skip this step !

    1. Open Control Panel
    2. Scroll through Power options
    3. Select Choose what the power buttons do
    4. Click on Change settings that are currently unavailable
    5. Under Shutdown settings, uncheck Turn on fast startup & Save changes
    6. Shutdown Windows
  • Disable Secure Boot & Fast Startup , under BIOS settings

  • Check Boot Priorities, set Ubuntu as first priority in Boot Priorities

  • Save Changes & Exit BIOS settings.

  • Hope this solved your problems, if not post the errors you encountered (Hopefully None) (*_^)

  • I did this previous didn't solve my issue. Still cant see windows in GRUB menu. – Sudo Aug 31 '18 at 18:04
  • Did you tried GRUB update option ? – Ankit Pandey Sep 1 '18 at 5:31
0

Solved Did not have much data on windows drive so reformatted and installed to UEFI then later installed Ubuntu on second drive.

Windows is now in GRUB

Thanks.

Not the answer you're looking for? Browse other questions tagged or ask your own question.