21

I make extensive use of the multiple timezone clock feature in 16.04.

After upgrading to Ubuntu 18.04 I found various guides that installing GNOME Clocks and adding time zones I should see them in the dropdown when I click the clock on the taskbar.

However it isn't showing up in there, despite restarting a few times.

I also installed GNOME Weather and its section shows now in the clock dropdown.

Has anyone else had this problem? Ideas on how to fix this?

1
43

GNOME Clocks should work fine if it's set up correctly. However, if you have installed the application from the (GNOME) Software application, there is a chance that you have installed the snap version of Clocks. You can verify that by running snap list and checking whether the output contains gnome-clocks.

If that is the case, this behaviour is not very surprising given the security restrictions of snap packages. To fix this remove the snap application by running

snap remove gnome-clocks

and install the traditional one by running

sudo apt install gnome-clocks

Then you should be able to find added time zones in the date & time dropdown tray (N.B. You may have to log out and back in).

enter image description here

5
  • 1
    Doesn't show up. The World Clocks section is not there. – Bishwas Mishra Mar 9 '19 at 9:54
  • 4
    @BishwasMishra Try logout and login again. – karel Mar 9 '19 at 14:44
  • 2
    I think you're right @karel. This is mentioned in the other answer I wrote previously, where OP confirms that relogin is required. – pomsky Mar 9 '19 at 14:52
  • 11
    They also show up after a reload of Gnome (without needing to log out/in): Alt + F2, type "r" (without quotes), and Enter – Adam Westbrook Feb 20 '20 at 12:00
  • 1
    This works for Ubuntu 20.04. – Nav Jul 13 '20 at 22:40
4

@pomsky answer (replacing snap package with apt package) works for me as well. In addition, I also like to use gnome extension panel-world-clock-lite to make it always visible on the task bar:

enter image description here

EDIT:

To install it:

  1. Install Gnome Clocks and Gnome Tweak Tool

    sudo apt install gnome-clocks sudo apt-add-repository universe sudo apt install gnome-tweak-tool

  2. Install panel-world-clock-lite

  3. Open Gnome Clocks and add timezones to be shown

  4. Open Gnome Tweak and enable "Panel World Clock" extension

  5. Reboot your computer

2
  • Seems super cool. Do you have references on how to install this on top of Gnome's clocks? Wasn't able to find it in snap/apt stores for ubuntu. – Naz Mar 15 at 22:04
  • @Naz, (1) install Gnome clocks via apt-get, (2) install Gnome tweaks, (3) enable extension "Panel world clock (lite)" – surfingonthenet Mar 15 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.