0

I am trying to to open PDF files with Krusader but it does not do anything when I click on a pdf file (or hit Enter).

I set the system default application for pdf files so when I open the Ubuntu's default file browser and click on any pdf file it opens with Document Viewer. That is fine.

But when I do the same in Krusader nothing happens.

How can I tell to Krusader to use Document Viewer for open pdf files?

UPDATE

It seems that Krusader uses different applications to open files. For example Ubuntu's file browser uses Image Viewer to open jpg files but same image file is opened with Firefox by Krusader.

0

I just installed krusader on Ubuntu 18.04.1, fully updated, to see if I could reproduce your problem.

apt policy krusader has Installed: 2:2.6.0-1.

Without making any changes to any settings, including

"I set the system default application for pdf files so when I open the Ubuntu's default file browser and click on any pdf file it opens with Document Viewer. That is fine."

double-clicking on a pdf file in krusader opened the pdf file in Document Viewer.

Open pdf files in Document Viewer from Krusader

Could it be that when you installed krusader you used the --no-install-recommends option to reduced the number of files pulled in? Or is it possible that the "changes" you made to the system defaults, as quoted from your question, had this effect?

I suggest you

  • purge your existing krusader install
  • rename ~/.config/krusaderrc to something else at least temporarily
  • reinstall krusader allowing all recommends which should be the default anyway.
  • 1
    Originally I have installed krusader from 'Ubuntu Software' application. I removed completely krusader as per your suggestion and installed krusader again with apt-get. Now it works fine. Thx. – zappee Sep 1 '18 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.