I have recently a purchased Lenovo Thinkpad E480 laptop, I have installed Ubuntu 18.04 on it, everything is working fine except am not able to connect to network via WiFi. Please help.

I followed this link, but am unable to solve the issue.

Below are the outputs of some commands.

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:   bionic

uname -r


rfkill list all

0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

lspci -nnk | grep 0280 -A3

05:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
    Subsystem: Lenovo RTL8821CE 802.11ac PCIe Wireless Network Adapter [17aa:c024]
06:00.0 SD Host controller [0805]: O2 Micro, Inc. SD/MMC Card Reader Controller [1217:8621] (rev 01)
    Subsystem: Lenovo SD/MMC Card Reader Controller [17aa:5068]

sudo lshw -C network

       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 10
       serial: 8c:16:45:a3:d9:f1
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:16 ioport:d000(size=256) memory:f1204000-f1204fff memory:f1200000-f1203fff
  *-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:c000(size=256) memory:f1100000-f110ffff

It seems I have to clone, compile and install the required WiFi driver, please guide me which WiFi driver to use and how to install (with steps if possible).

P.S.: Let me know if any further information is needed to solve this issue, I will add the required info (if any) in the question as per the guidance given.


With a temporary working internet connection by ethernet, tethered or any other means, open a terminal Ctrl+Alt+t and do:

sudo apt update
sudo apt install build-essential git dkms
git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce
sudo ./dkms-install.sh

The file builds for me on my 18.04 system with a few possibly harmless warnings but no errors.

Follow with:

sudo modprobe 8821ce

You should be all set.

  • Excellent, that worked perfectly fine. I am typing this comment on my WiFi Connection. – Sunny Shukla Aug 30 '18 at 21:45
  • 1
    Thanks it worked for me as well on Lenovo ideapad 130 model, typing on wifi connection:) (last cmd- "sudo modprobe 8821ce" gave error but restarted machine and wifi started working, without re-running the last cmd again) – Waseem Oct 31 '19 at 20:22
  • Worked on HP 255 G7 Ryzen 3 with Ubuntu 20.04 – berduchwal Sep 30 '20 at 8:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.