0

I've downloaded/tested the USB live version of Ubuntu 18 on my Desktop and decided to try and install it on my laptop. The laptop is a bit older, runs a 64bit CPU (Intel Q9000). When I try to boot to the USB drive, I see first the regular boot screen (keyboard + circle on bottom), followed by a command line blinking. Then, the screen goes into a pixel test mode, showing all RGB + grayscale test patterns and I hear a drum sound once.

When I try F4 to enter the debug mode, the same issue happens after selecting install.

Any advice?

9
  • 1. Did you check the download with md5sum? 2. How did you create the USB boot drive (with which tool)? 3. Please specify your computer (brand name and model).
    – sudodus
    Commented Aug 30, 2018 at 17:02
  • 1. Checked, checksum checks out. As mentioned, the USB drive works with my desktop computer and starts Ubuntu there. 2. Rufus 3. Acer Aspire 8930g, Q9000 CPU, Nvidia 9600M, 4GB Memory, 1TB HDD
    – petaris
    Commented Aug 30, 2018 at 17:04
  • I think you need the boot option nomodeset to make it work with that graphics card. The following link and links from it can help you enter nomodeset in the correct way, Boot options
    – sudodus
    Commented Aug 30, 2018 at 17:12
  • You are welcome :-)
    – sudodus
    Commented Aug 31, 2018 at 4:32
  • After installation and booting linux from HDD it is doing the color test again. How can I permanently modify to have nomodeset set as default for booting? How can I use grub to force a start in nomodeset? I only have command line grub available to me, the installation messed something up, because I have two HDDs and grub landed on the wrong one. Here is what I did: Just booted Linux Live, chrooted my installed linux drive and tried to edit /etc/default/grub . However I found that "nomodeset" is already saved in that file. Is there another place where grub accesses this nomodeset data?
    – petaris
    Commented Aug 31, 2018 at 8:06

1 Answer 1

0

Live drive

I think you need the boot option nomodeset to make it work with that graphics card. The following link and links from it can help you enter nomodeset in the correct way, Boot options.

Installed system

After installation you can

  • use nomodeset again (with grub), and you can add it such that it persists. See this link

    Grub2/Setup - /etc/default/grub

    Scroll down to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash", where you can add nomodeset to make it

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
    

    and after you have saved the edited file

    sudo nano /etc/default/grub
    

    run

    sudo update-grub
    
  • The next step is to install an nvidia proprietary driver to make Ubuntu work with your graphics chip/card. Try according to the following links

    How do I install the proprietary Nvidia drivers on Ubuntu 17.10?

    Installing NVIDIA proprietary drivers?

    You can list the available driver packages with the following command line,

    LANG=C apt-cache policy nvidia*|grep -B2 -E 'Candidate.*ubuntu'
    

    nvidia-384 is the driver package with the highest revision number, that I find in my 18.04.1 LTS system, and it can be installed with

    sudo apt install nvidia-384
    

    You can start trying with that package.

  • But sometimes the free nouveau driver, that is installed automatically, will work better than the best proprietary driver.

4
  • Nomodeset is already in the grub file. I edited it with nano. My problem is, when I do mount /dev/sdb1 /mnt/root and mount /dev/sdb6 /mnt, grub-update finds only Windows 10 on sdb1, but not linux on sdb6. It then writes the config file into /dev/sdb1/grub/grub.cfg. However, when I do only mount /dev/sdb6 /mnt it finds both linux and Windows 10. It proceeds then to write the grub.cfg into an unknown location. To check if it writes there, I removed grub.cfg file from sdb1 and it wasn't there. I assume it writes it on the initial grub installation on some partition of drive sda.
    – petaris
    Commented Aug 31, 2018 at 9:15
  • Booting with grub via command line results in failure - either in color test mode (it doesn't read the config file /sdb6/etc/default/grub which you mentioned above, but nomodeset is there!). Or, if I try to add nomodeset to the linux command line linux /boot/vmlinuz-4.15.0-29-generic nomodeset it results into a boot error/halt. I can't successfully boot into the installed Linux to install the drivers.
    – petaris
    Commented Aug 31, 2018 at 9:18
  • howtoubuntu.org/… This is the guide I used which successfully located both Linux&Windows. I checked the grub folder if a config file was created in the correct location (it wasn't). Then I mounted all drives of sda I could find using lsblk and searched for a grub folder which did not find. My intention was to copy the config file over to /sdb1/grub
    – petaris
    Commented Aug 31, 2018 at 9:47
  • Can you boot into the installed system (with 'nomodeset` added at the grub menu), when the live drive is not connected?
    – sudodus
    Commented Aug 31, 2018 at 10:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .