1

First off - very much a newbie with Ubuntu. Have been running it on an old computer for about 12 months with a TOR relay running.

Followed multiple how-to's and finally got it working. However, just updated to 18.04 last night and for the life of me I cannot get my relay up and running again. I've Googled everything, ran almost every command I can find and I keep getting the same basic problem.

Previous I ran arm to monitor the relay, but after the upgrade that was gone and so I installed NYX. When I tried to run that it says "Unable to connect to tor. Are you sure it's running?" (no - I have no idea, I assumed it was).

$ tor
Aug 30 22:01:00.220 [notice] Tor 0.3.3.9 (git-ca1a436fa8e53a32) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.1.0g, Zlib 1.2.11, Liblzma 5.2.2, and Libzstd 1.3.3.
Aug 30 22:01:00.220 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Aug 30 22:01:00.220 [notice] Read configuration file "/etc/tor/torrc".
Aug 30 22:01:00.224 [notice] Based on detected system memory, MaxMemInQueues is set to 2862 MB. You can override this by setting MaxMemInQueues by hand.
Aug 30 22:01:00.225 [notice] Scheduler type KIST has been enabled.
Aug 30 22:01:00.225 [notice] Opening Socks listener on 127.0.0.1:9050
Aug 30 22:01:00.225 [notice] Opening Control listener on 127.0.0.1:9051
Aug 30 22:01:00.225 [notice] Opening OR listener on 0.0.0.0:9001
Aug 30 22:01:00.225 [notice] Opening Directory listener on 0.0.0.0:9050
Aug 30 22:01:00.225 [warn] Could not bind to 0.0.0.0:9050: Address already in use. Is Tor already running?
Aug 30 22:01:00.225 [notice] Closing partially-constructed Socks listener on 127.0.0.1:9050
Aug 30 22:01:00.225 [notice] Closing partially-constructed Control listener on 127.0.0.1:9051
Aug 30 22:01:00.225 [notice] Closing partially-constructed OR listener on 0.0.0.0:9001
Aug 30 22:01:00.225 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Aug 30 22:01:00.225 [err] Reading config failed--see warnings above.

I figured for whatever reason, it wasn't installed correctly. I followed the install instructions on the TOR Project website and did it again. Same message.

I figured, maybe better to remove it all and start again, so I ran:

sudo apt-get remove --auto-remove tor

Then ran through the whole install process again. Same result / error.

My torrc file appears to be the original one, as whenever I edit it to check, it had all the original settings I had from my previous relay set up.

Found two other threads here that was almost the same (except different IP address), so I also tried all the solutions suggested, including:

killall tor
tor:no process found

But no change - I'm not sure if it's actually a TOR issue, an IP address issue, have I somehow now install 4 copies of TOR?

Sidenote - Was able to install TOR Browser and that works fine.

I'm keen to get my relay up and running, so I'd be grateful for any advice offered. TIA

Tried that suggestion:

Thanks for the reply, unfortunately I'd already tried this and it appears that tor isn't actually running:

ben@ben-OptiPlex-755:~$ ps aux | grep -i tor
ben       2435  0.0  0.2 299360  8828 ?        Ssl  11:27   0:00 /usr/lib/gvfs/gvfs-udisks2-volume-monitor
ben       2442  0.0  0.1 371736  7616 ?        Ssl  11:27   0:00 /usr/lib/gvfs/gvfs-afc-volume-monitor
ben       2447  0.0  0.1 281680  6616 ?        Ssl  11:27   0:00 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
ben       2454  0.0  0.1 268764  6056 ?        Ssl  11:27   0:00 /usr/lib/gvfs/gvfs-mtp-volume-monitor
ben       2458  0.0  0.1 266968  5916 ?        Ssl  11:27   0:00 /usr/lib/gvfs/gvfs-goa-volume-monitor
ben       2593  0.0  0.2 464988 10476 tty2     Sl+  11:27   0:00 /usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service
ben       2603  0.0  0.2 366280  7828 tty2     Sl+  11:27   0:00 /usr/lib/x86_64-linux-gnu/indicator-messages/indicator-messages-service
ben       2636  0.0  1.6 884620 66384 ?        Ssl  11:27   0:00 /usr/lib/evolution/evolution-calendar-factory
ben       2704  0.0  1.5 1054588 61800 ?       Sl   11:27   0:00 /usr/lib/evolution/evolution-calendar-factory-subprocess --factory all --bus-name org.gnome.evolution.dataserver.Subprocess.Backend.Calendarx2636x2 --own-path /org/gnome/evolution/dataserver/Subprocess/Backend/Calendar/2636/2
ben       2733  0.0  0.6 725764 24104 ?        Ssl  11:27   0:00 /usr/lib/evolution/evolution-addressbook-factory
ben       2746  0.0  0.6 1075752 26984 ?       Sl   11:27   0:00 /usr/lib/evolution/evolution-addressbook-factory-subprocess --factory all --bus-name org.gnome.evolution.dataserver.Subprocess.Backend.AddressBookx2733x2 --own-path /org/gnome/evolution/dataserver/Subprocess/Backend/AddressBook/2733/2
ben       3786  0.0  0.8 101515084 32172 tty2  Sl+  11:29   0:00 /usr/lib/deja-dup/deja-dup-monitor
ben       4383  0.0  0.0  14428  1088 pts/0    S+   11:40   0:00 grep --color=auto -i tor

Or is that very last process 4383 the Tor process? Nope, doesn't appear so as it says no such process when I run

kill -9 4383

Other suggestions? :)

0

Can you please get the running tor process, and kill it:

ps aux | grep -i tor

It will show you the tor process id, Now you can kill it, if it's running:

kill -9 process_id

Hope this will help you. :)

  • Thanks NOrbert for the edit and correcting the sentence syntax. – Ram Krishna Aug 31 '18 at 12:26
  • Thank you - tried those commands, but didn't fix it. Original posted updated. – ben981 Sep 1 '18 at 1:54
  • What is the error message, when you are reinstalling tor. – Ram Krishna Sep 3 '18 at 11:56
  • I don't get an error when it's installing, Tor appears to install fine. But when I run nyx it says "Unable to connect to tor. Are you sure it's running?" Hence the reason I run the Tor command to get that initial message at the top. It appears Tor can't get itself booted up. – ben981 Sep 5 '18 at 10:30
0

OK so the guys over on the Tor-Relay mailing listed solved my issue: I had too many things trying to access the same ports. ie SOCKS & Directory Listener were both trying 9050.

Once I changed all the ports to separate ones, it was happy!
ie

  • Control Port 9030 - not required to be open on the router.
  • DirPort 9051 - open on the router.
  • SOCKS 9050 - not open on the router.
  • OR Port 9001 - open on the router.

As stated above, I had two trying to get out through the same port - Doh!!

Thanks to the advice offered though :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.