19

Ive hooked up an external monitor to my netbook. On my desk the external monitor is placed to the left of my netbook. To navigate from the netbook monitor to the external monitor i have to move the mouse off to the right. I find this slightly disorienting. Is there a way to configure this so that i can just move my pointer to the left, towards the external monitor?

3
  • What graphics card do you use? (This should be easy with the standard Monitor configuration dialog when you have a graphics driver that supports xrandr properly.)
    – JanC
    Nov 1 '10 at 11:54
  • Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
    – Detnuomnu
    Nov 2 '10 at 7:52
  • Did the answer work? If so, if you could mark it as the Accepted Answer that'd be great. :)
    – jrg
    Jun 7 '11 at 15:58
30

I wasn't able to solve this one in 10.10 with gnome monitor manager. Have since upgraded and distro/wm hopped a bit so can't follow up on this. However I have discovered arandr which i now use for monitor management in the lighter wm's (LXDE and Awesome). Its in the repositories.

sudo apt-get install arandr

After installing, open your terminal and type arandr, then change the position of your devices according to your need.

4
  • 2
    Just in case it isn't clear, ARandR (which actually stands for "Another XRandR GUI") is a visual front end for XRandR that allows easy manipulation of relative monitor positions via simple drag-and-drop. Pretty convenient!
    – waldyrious
    May 20 '18 at 22:24
  • 1
    Bloody marvellous utility, works on 17.04 also!
    – Vix
    Jun 16 '18 at 19:26
  • 1
    Just saved my bacon in 18.04
    – Álex
    Feb 11 '19 at 9:24
  • This answer is a decade old and still perfectly valid and useful. +1
    – Criggie
    Mar 3 at 22:00
6

On Ubuntu 18.04 go to Settings->Devices->Displays.

In Display arrangement both your displays will be shown. Drag the secondary display to match your preferred setup (switch the two displays in your specific case).

1
  • I did what Mil says in my newly-upgraded 18.4 and it worked perfectly. Until now: after rebooting the system forgot my settings and the "Devices" option disappeared. I fixed it with the arandr thing brought by @Detnuomnu (fine!) but remained intrigued about where did my options go?
    – Juan Lanus
    Sep 9 '18 at 23:49
2

In KDE you can go to "System Settings"->Hardware->"Display and Monitor"->There you can configure everything related to orientation of picture and orientation between monitors.

Similar tool is in Gnome desktop environment under System.

Also, if you are using ATI proprietary drivers included tool amdcccle can be used to configure these settings.

That can also be done with xrand passing arguments, or through xorg-conf. For these, please look up respective man entries on what arguments should be passed.

Cannot say how that can be done using nVidia cards as i have never used those.

1
  • @Detnuomnu Seven years after your post... I'm running Budgie window manager on Linux Mint, this solution worked perfect for me.
    – Paul J
    Jun 14 '18 at 15:43
2

I found that, after configuring 'Display & Monitors' lots of apps open in the auxiliary monitor, which isn't what I want. To change that, go to System Settings > Window Behaviour > Window Rules. For each app (it's only a few), I make a rule: 'New...'. With the app open, click 'Detect Window Properties' then click in the app's window: it fills in the properties automatically (neat!). In 'Size & Position' I set the Position to 'Remember' & 'Screen' I set to 'Remember' & '2'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.