1

I upgraded my ubuntu distribution from 16.04 to 18.04. On 16.04, an external monitor (VGA plug) and the ethernet connection were working well. Since the upgrade, I obtain very strange behavior of the ethernet connection and of the external monitor. The monitor is detected and then turns black. The ethernet connection appears and disappears. I tried to plug a mouse and a flashdrive on displaylink and they both work well. When the display link is plugged with either the ethernet cable or vga cable the audio output detects it and changes the volume continuously.

When I write

lsusb -d 17e9:

I obtain sometimes (when nothing is plugged on the displaylink) Bus 002 Device 112: ID 17e9:436f DisplayLink and sometimes nothing...

I tried to install the new version of the displaylink driver and used https://github.com/AdnanHodzic/displaylink-debian.

If someone has already encountered the same problem and knows how to fix it, it would be great help...

ALTERNATIVE QUESTION: does anyone know if plugging external monitor via a thunderbolt has more chance to work on ubuntu 18.04 ?

Pierre

  • After some investigations, it seems that the main problem is that display link disconnects after some minutes whatever the ethernet or the vga cable is plugged in. – Pierre Barbillon Aug 29 '18 at 19:49
  • At last, I bought a thunderbolt adapter for vga, hdmi and usb and it works perfectly fine on ubuntu 18.04, so I guess the best solution is to give up display link usb adapters.... – Pierre Barbillon Sep 28 '18 at 13:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.