0
*-network DISABLED
       description: Wireless interface
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlo1
       version: 00
       serial: f8:da:0c:00:fe:2b
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723de latency=0 multicast=yes wireless=unassociated
       resources: irq:131 ioport:3000(size=256) memory:b1000000-b100ffff

Once in a while, Bluetooth says to plug in a dongle to use Bluetooth which is back to normal after a restart. But wifi is always disabled

Tried rfkill unblock all .. didnt work Rfkill list all shows Wireless lan Soft and hardblocked as no Bluetooth
Soft and hard blocked as no

0

This will not be a complete answer as I believe we will have to correct a few things and check again before we reach the solution.

First, we notice that you have a Broadcom wireless driver installed. Your device is a Realtek. Let's remove the incorrect driver:

sudo apt purge bcmwl-kernel-source

Second, we notice that both Wicd and Network Manager are installed. New in Ubuntu 17.10 and later is networkd and netplan. Netplan clearly says NM is in charge. From your readings:

[/etc/netplan/01-network-manager-all.yaml]
network:
  version: 2
  renderer: NetworkManager

I recommend that you remove Wicd:

sudo apt purge wicd*

After doing so, tell us if this line remains in NetworkManager.conf

cat /etc/NetworkManager/NetworkManager.conf 

Does this line remain after removing Wicd?

[keyfile]
unmanaged-devices=interface-name:wlo1

If it remains, we will need to edit the file to remove it.

Once these steps are taken, reboot and report back your result and we'll continue if needed.

EDIT: Please remove the keyfile section; from the terminal:

sudo nano /etc/NetworkManager/NetworkManager.conf 

Remove this section completely:

[keyfile]
unmanaged-devices=interface-name:wlo1

Save (Ctrl+o followed by Enter) and close (Ctrl+x) the text editor.

Restart NM:

sudo service network-manager restart

It might take a reboot. Any improvement?

  • [keyfile] unmanaged-devices=interface-name:wlo1 the line still remains – rohit deraj Aug 30 '18 at 4:58
  • Should i just delete these two lines? – rohit deraj Aug 30 '18 at 13:18
  • Yes, as I will suggest in an edit in a few moments. – chili555 Aug 30 '18 at 13:34
  • No improvements ... wifi in settings now shows unavailable instead of unmanaged. FYI For once wifi worked today then after reboot it didn't work ( THIS IS BEFORE REMOVING keyfile) . The network was not disabled at that time.. so there is a small probability that my wifi works if I keep rebooting again and again but why?? – rohit deraj Aug 30 '18 at 17:53
  • Instead of rebooting, does it work with: sudo service network-manager restart? – chili555 Aug 30 '18 at 19:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.