13

I have a new XPS 13 9670 with Ubuntu 18.04.

A bunch of applications often (but not always) think I'm dragging. For example, when using GNote and my house hovers over my list of notes, it will attempt to drag it.

I have this with a number of applications. The Telegram desktop application too, but oddly enough not every application. Could this be a hardware problem, or is it something I can fix in software?

  • 1
    There is an accessibility feature that does exactly that, but I'm not sure how it is called (drag-lock maybe?). Please check your accessibility settings. This question may be helpful. – danzel Aug 29 '18 at 13:03
  • Hi @danzel! Thanks for the suggestion. I took a lock at the Drag Lock feature via xinput. It does seem to be disabled for me. – Evert Aug 29 '18 at 13:14
  • Using dconf I found a setting called /org/gnome/desktop/peripherals/touchpad/tap-and-drag which was enabled, I wonder if this causes it. – Danny Varod Mar 5 at 11:32
12
+50

I had the same issue in multiple applications including Okular, Eagle etc. I accidentally discovered that it might be related to the touchscreen. While in the 'dragging mode' in Okular, I could get out by simply tapping on the touchscreen once. I then experimented by explicitly touching the screen (and not taking my finger off) and immediately, the pointer started dragging. I suspect one possible cause for the behavior is spurious touch detects without the corresponding release being detected.

| improve this answer | |
  • 1
    Although it didn't solve my problem, this exactly explains what happened to me. I wasn't really using the touchscreen so I turned it off (sadly) which completely eliminated this. When a solution comes along on askubuntu.com I'll give the 'solved' flag to the new answer, but this was helpful until then. Thank you. – Evert Nov 19 '18 at 18:07
  • 2
    Thank you! It was the touchscreen for me too. For the record, you can get the name of input devices with xinput list and add this to your ~/.xprofile file to disable it: xinput set-prop $ID 'Device Enabled' 0 – Tobia Jun 10 '19 at 20:38
  • I know you're not supposed to make "thank you!" comments but.... THANK YOU! I've been having this for SO LONG and the only way to resolve this I knew was to reboot. This is such a relief! In fact let me scrap together some reputation as a thank you! – Christian Apr 1 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.