6

Since upgrading to 18.04 from 16.04 I have been seeing the following message:

➜  ~ hwe-support-status 

You have packages from the Hardware Enablement Stack (HWE) installed that
are going out of support on 2023-04-30.

To upgrade to a supported (or longer-supported) configuration:

* Upgrade from Ubuntu 16.04 LTS to Ubuntu 18.04 LTS by running:
sudo do-release-upgrade -p

OR

* Switch to the current security-supported stack by running:
sudo apt-get install linux-generic-hwe-18.04

and reboot your system.
➜  ~ hwe-support-status --show-all-unsupported
➜  ~ hwe-support-status --show-replacements
linux-generic-hwe-18.04
➜  ~ sudo apt-get install linux-generic-hwe-18.04
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-generic-hwe-18.04
E: Couldn't find any package by glob 'linux-generic-hwe-18.04'
E: Couldn't find any package by regex 'linux-generic-hwe-18.04'
➜  ~ sudo do-release-upgrade -p
Checking for a new Ubuntu release
No new release found.
➜  ~ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:        18.04
Codename:       bionic
➜  ~

Does anyone know why this is happening?

  • There is no such package in Ubuntu repositories now. It is very likely that it will be created later as linux-generic-hwe-16.04. See this page. – N0rbert Aug 29 '18 at 9:30
  • Can this basically be ignored then? – fooquency Oct 1 '18 at 11:22
  • 2
    You probably have some version of the hwe kernel package installed - very likely if you did the hwe update in 16.04. If you did an apt policy linux-generic* you could see what kind of kernel packages you have installed. Likely you could just remove the offending hwe package then, as long as you have another kernel package installed, of course. – Organic Marble Oct 28 '18 at 16:04
  • Fixed! Thanks to Organic Marbles reply :) "apt policy linux-generic" showed I had "linux-generic-lts-vivid" installed, I removed this but was still getting the warning. I then altered the hwe-support-status script so it actually told me which package was unsupported and discovered I also had "linux-headers-generic-lts-vivid" installed (in hindsight, I should have ran apt autoremove after removing the old kernel). – Chris Nov 10 '18 at 19:54
3

No specific hwe or lts linux-image is yet required for 18.04 (so it doesn't exists). Ensure first that linux-image-generic image is installed:

 apt install linux-image-generic

Then remove old hwe or lts linux images, in my case I did:

apt purge linux-image-generic-lts-xenial

Then the hwe-support-status command returns a clean empty response.

| improve this answer | |
  • I had to use aptitude to identify and purge the old, unused *-lts-* images. After doing it, everithing is OK. – baronKarza Dec 12 '18 at 16:09
1

I had an old unsupported Linux kernel installed, discovered using

# apt policy linux-generic\*

Remember to run

# apt autoremove
to remove any unused dependencies which may also be picked up by hwe-support-status.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.