Did the following as normal user and reboot, still not working

gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state

Did the above as root got answer:

(process:3378): dconf-WARNING **: 14:35:23.197: failed to commit changes to dconf: Erreur lors de la génération de la ligne de commande « dbus-launch --autolaunch=0f76e53a9e0b4f1f8ddd7b2736e88499 --binary-syntax --close-stderr » : Le processus fils s’est terminé avec le code 1

gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state

Next ? Purchase new keyboard still not working, funny the maths key ∕⋅−+ works but not the numbers


Problem solved.

  1. Click on triangle top right corner
  2. Click on the icon wrench
  3. Click in the left column on Universal Access
  4. Go to the bottom of the page deactivate mouse keys (it is the first line in the box)
    enter image description here

Don't run this command as root/sudo ! Instead run it as user.

gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state 

To turn on the numlock type

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

Maybe programatically setting numlock will help you, based on numlock being reverted when switching keyboard layouts.

  • Thank you abu bua for your answer, did tried it out priviously but it did not work – Gill Sep 2 '18 at 17:32
  • you should try another keyboard in the settings. – abu_bua Sep 2 '18 at 17:34
  • 1
    1- Go to Adjustment 2-Go to Keyboard and mouse 3-Click on supplemtary options 4-In list click on numeric keypad disposition 5-I took the first UNICODE Keypad is working normaly (sorry for translation my computer is in french) – Gill Oct 10 '18 at 14:19

On a mac keyboard the "clear" key functions as the number lock key.


After looking around the Menu I found the answer as follows:

Preference >accessibility > Mouse: "Control the Pointer using keypad" Turn it OFF!

Ubuntu 18.04:

Srttings > universal Access > pointing and clicking: "Mouse keys" Turn it OFF!


Choose appropriate keyboard

Settings --> Region & Languages --> Input Sources --> Click add + --> Select your keyboard language --> Check if all the keys works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.