0

I have VisualSVN Server running on a Windows box. I can access this with no problem in a variety of ways:

  • Using svn on command line in Debian Linux client when connected to the client via ssh
  • Through multiple web browsers on multiple machines
  • From my Ubuntu machine when I'm sitting at the machine and using lxterminal in the desktop environment.

I cannot, however, complete a transaction when logged into that same Ubuntu machine remotely via ssh. When I execute any svn command that requires communication with the server in the ssh terminal window, it finds the server and asks for authentication, as it should, but then it hangs with no output once the credentials are provided. I can see on the server side that it requests data and that no errors are logged, but I have not been able to see what happens beyond that.

From the desktop, where it works, instead of being prompted for my password in the lxterminal window, I get a graphical dialog box. I'm not sure if that's related or not.

Additional information that may or may not be relevant:

  • OS of machine with problem: Linux 4.15.0-33-generic #36-Ubuntu SMP Wed Aug 15 16:00:05 UTC 2018
  • Version of svn client on machine with problem: svn, version 1.9.7 (r1800392)
  • The client in question is a virtual machine running in Oracle VM on a Windows 10 host
  • Access to the VisualSVN server is through a proxy server. The proxy server is an Ubuntu VM running the same version of the OS and Apache. (As noted, the proxy works fine when accessed from multiple different machines running different OS.)
  • Working command line client SVN versions include:
    • svn, version 1.8.9-SlikSvn-1.8.9-X64 (SlikSvn/1.8.9) X64 (DOS prompt from Windows 10)
    • svn, version 1.8.10 (r1615264) (Debian Linux box)
  • Protocol used in all cases is http, e.g. svn list http://svn.example.com/svn/myproj
  • All machines involved are on a private network. In some cases that includes VPN, but the VPN works for the non-Ubuntu machines with no apparent problems.

1 Answer 1

1

I did some further experiments with my laptop sitting next to the Ubuntu machine that was causing me problems. With them next to each other, I noticed that after I entered my svn password in the ssh session started from the laptop, I was getting a keyring dialog box in the desktop session. That's terrible behavior since I'm generally using ssh because I don't have access to the machine, but it was entirely the culprit. If I clicked "Cancel" in that dialog box in the desktop session, the svn transaction in the ssh terminal would complete.

Armed with that information, I was able to track an apparently permanent fix. In the file ~/.subversion/servers toward the bottom, there is an option commented out for store-passwords = no. I uncommented that, and now it seems to work. It doesn't store the password, but that's what I wanted anyway.

1
  • Unbelievable...
    – drakorg
    Jul 10, 2021 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.